WebPagetest Forums
setCookie not working any more - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: setCookie not working any more (/showthread.php?tid=14844)



setCookie not working any more - javrok - 04-06-2017 09:43 PM

Hi, I was using the 'setCookie' property to bypass a cookiewall on my tests, and it stopped working a few days ago. I didn't change anything, I think some change was introduced on the server, seeing the recent github commits.

It stopped working around 4th april 14h GMT.
I'm using Amsterdam, NL - IISpeed - Firefox - Native

Thanks !


RE: setCookie not working any more - mverkerk - 04-07-2017 03:58 AM

I think i may be suffering from this too ... i ran a script about a month ago which had a 'setCookie' command and it worked but the same script doesn't work right now ...
I'm using a private instance with agents running on version 371 (same as public wpt agents)
Note: I tried both Chrome and Firefox - same issue


RE: setCookie not working any more - javrok - 04-07-2017 05:58 PM

Yeah, I think is a bug introduced on the latest release. Let's just wait for Patrick to take a look Smile


RE: setCookie not working any more - akshayranganath - 04-08-2017 03:07 AM

This issue appears to have been raised as a bug on the WPO github: https://github.com/WPO-Foundation/webpagetest/issues/844


RE: setCookie not working any more - javrok - 04-26-2017 11:21 PM

Hi, I just discovered that the problem is happening only in Firefox. Here are two exact tests with scripting, setting a cookie to remove the cookie bar (on the top of the screenshot):

- Chrome https://www.webpagetest.org/result/170426_C6_Z75/
- Firefox https://www.webpagetest.org/result/170426_CQ_Z4V/
You can see the setCookie worked on Chrome but not on Firefox.

I see something different, though, if I use the API (npm), but it also fails. I think this functionality needs to be reviewed with the update.

Thanks