WebPagetest Forums
Unable to see results for a flow with 2-3 steps - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Unable to see results for a flow with 2-3 steps (/showthread.php?tid=14854)



Unable to see results for a flow with 2-3 steps - sammyprabh - 04-11-2017 04:16 AM

Hi,

I am running a test on a private instance and trying to do the following


navigate <URL for page 1>
setValue name=userName <value>
setValue name=/atg/userprofiling/ProfileFormHandler.value.password <value>
submitForm name=loginForm
navigate <URL for page 2>
navigate <URL for page 3>
navigate <URL for page 4>

I am able to see the private instance loading all the urls and navigate to the right pages but when the test is done i dont see results for any of the pages except the 1st one. Can someone help me with this ?

I tried the same script in public instance and it worked fine.


RE: Unable to see results for a flow with 2-3 steps - rikiki61 - 04-11-2017 05:37 PM

Hi,
I think you should first check if it happens navigation, to do that you must run the script while viewing the screen of the tester;
if you see that navigation is done for pages 1,2,3 and 4
try to put "combineSteps" command at the beginning of the script to see the sum of the load time in the results.
I hope I have understood and have been of help


RE: Unable to see results for a flow with 2-3 steps - sammyprabh - 04-13-2017 08:42 AM

(04-11-2017 05:37 PM)rikiki61 Wrote:  Hi,
I think you should first check if it happens navigation, to do that you must run the script while viewing the screen of the tester;
if you see that navigation is done for pages 1,2,3 and 4
try to put "combineSteps" command at the beginning of the script to see the sum of the load time in the results.
I hope I have understood and have been of help

Thanks . This helped a bit .I'm at-least able to get the sum of all pages now.
Without combinedsteps ,when i run the script i am able to see the browser getting loaded and navigating to every page that is in the script. Somehow only the 1st page results are shown. I was looking for a breakdown per page something like this
https://www.webpagetest.org/result/170412_2Q_1N5K/. Any idea how i can get this?