WebPagetest Forums
Install/configure Docker images - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Install/configure Docker images (/showthread.php?tid=15003)



Install/configure Docker images - caleb - 08-10-2017 04:51 AM

Hello! I am attempting to run the WPT server and agent docker images, and having some trouble getting things connected. First (and most importantly), is there any documentation around working with the official images?

Here's the specific problem I'm currently trying to solve:

I have the server and agent containers running locally. The agent is polling the server, but the locations dropdown does not show the configured location. /install shows 0 agents connected for that location.

However, if I use the ?hidden=1 param I'm able to kick off a test, and the /install page then shows 1 agent connected. The test runs for as much as an hour and finishes with the "Test Data Missing" error.

I suspect there's some configuration mismatch between locations.ini on the server and wptdriver.ini on the agent, but I'm unable to find wptdriver.ini in the agent container.

Any ideas?


RE: Install/configure Docker images - caleb - 08-11-2017 08:52 AM

On this page:

https://hub.docker.com/r/webpagetest/agent/

There are multiple broken links to docs ("install", "run with docker" ). Do those docs exist? It looks like they might be helpful!


RE: Install/configure Docker images - francisjohn - 08-21-2017 12:57 PM

Hey Caleb --

I don't have an answer for the root issue but just wanted to point out the install docs exist on the github page for the wptagent docker container:

https://github.com/WPO-Foundation/wptagent

Thanks,
Francis