WebPagetest Forums
Time To First Byte problem - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Time To First Byte problem (/showthread.php?tid=15012)



Time To First Byte problem - malcolm88 - 08-17-2017 08:42 PM

Hi everyone,

I need some help in figuring out why Time To First Byte for my website is more than 1 second. Hopefully you guys able to help me reduce it to lower time. My website results:
https://www.webpagetest.org/result/170817_Z5_7e0eb34b2b520359d6905d750a99d62c/

I am using https://www.easystore.co/ which is like Shopify, but from Malaysia.
I am currently using CloudFlare DNS only mode.

I have tried asking the support from Easystore but doesn't help to be going anywhere on the problem.

Any help is appreciated! Thanks Smile


RE: Time To First Byte - amitt800 - 08-18-2017 07:34 AM

You needed to disable cloud-flare. some time is make TTFB slow.


RE: Time To First Byte problem - pmeenan - 08-19-2017 10:28 PM

In this case it's not a cloudflare or proxy issue since it is in DNS-only mode and that is not where the time is going. The 800-900 ms server response time is entirely in easystore's hands and unfortunately there isn't anything you are going to be able to do about it except for switching platforms unless their tech team is willing to investigate and optimize performance.


RE: Time To First Byte problem - malcolm88 - 08-20-2017 12:47 PM

Thanks Patrick for the info. I have been trying to reduce the Time to First Byte with little luck. I'll try to get the easystore team to investigate on this if possible.

Thanks once more Smile


RE: Time To First Byte problem - GreenGecko - 08-23-2017 07:12 AM

As an aside, I wouldn't use tools who think that mail can't be delivered unless a MX record it set if I were you!


RE: Time To First Byte problem - dfavor - 08-26-2017 11:37 PM

As Patrick suggested, get rid of CloudFlare.

Coarse testing I did with curl shows very slow response from CloudFlare, which is typical.

After you've removed CF, retry your testing.