WebPagetest Forums
WPT ConsoleLog does not match local Chrome Console Log - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: WPT ConsoleLog does not match local Chrome Console Log (/showthread.php?tid=15050)



WPT ConsoleLog does not match local Chrome Console Log - pmeyer - 09-17-2017 11:45 AM

Background ... Chrome is alerting users when they browse a website that is collecting a password or credit card & the website is not secure with HTTPS.

There is a website I'm testing on my local, I get this warning in the address bar "Not Secure" and in the console:

> This page includes a password or credit card input in a non-secure context. A warning has been added to the URL bar. For more information, see https://goo.gl/zmWq3m.

However, when I run the website in WPT, the consoleLog does not report this warning. It's reporting some other warnings, but not the security warning.

In WPT I checked the console log under the screenshot. And I also did an api call and the response 'consoleLog' does not have the security warning.

https://www.webpagetest.org/result/170917_DV_5ad99c8a3cf51da37affefb2dd5aa288/1/screen_shot/

Ideas or suggestions?

Thanks!


RE: WPT ConsoleLog does not match local Chrome Console Log - pmeyer - 09-25-2017 04:15 PM

Update. Is it possible Chrome on the test agent has console logs set to "errors" only? The message i'm looking for is an "alert" so maybe that's why it's not being displayed?