WebPagetest Forums
run test with edge - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: run test with edge (/showthread.php?tid=15082)



run test with edge - rikiki61 - 10-10-2017 08:33 PM

Hi all,
I need to run tests with microsoft edge and, for that, I have configured a dedicated tester inside a location of four testers:

Code:
Windows 10, if testing with Microsoft Edge (work in progress):
Install Python 2.7 for all users to c:\Python27 (default install directory)
Install selenium from a cmd shell
c:\Python27\Scripts\pip install selenium
Install pyWin32 from the agent folder (may need to be run from an administrator command prompt)
Install Imagemagick
Install Windows Performance Toolkit (uncheck all of the other options from the adk setup)

the problem is:
which is the correct syntax to include in wptdriver.ini?

I tried with https://github.com/MicrosoftEdge/edge-launcher but it does not work

thank you


RE: run test with edge - rikiki61 - 10-10-2017 10:20 PM

I found, reading in this forum, that you do not have to define the browser in wptdriver.ini, just put it in locations.ini and the agent knows what to do.

I have tried it and in fact it works fine

now my problem is:
as I did the full configuration for edge only on a one tester of the four inside the location,
when I send a new test to "location:edge.LAN" this is done by the first free tester and often is not the right one.

how can I make edge tests run by the dedicated tester only?

In the moment I solved creating a location for 1 tester with edge and a location with 3 tester for other browsers.

However, I see that edge performs single url tests but does not run scripts
AngryAngryAngryAngry