WebPagetest Forums
Windows 7 - wptagent - No connection could be made because the target machine activel - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Windows 7 - wptagent - No connection could be made because the target machine activel (/showthread.php?tid=15224)



Windows 7 - wptagent - No connection could be made because the target machine activel - nsecomdev - 02-03-2018 04:10 AM

Hello,

I'm in the process of setting up a private instance. WebPage Test is running in RHEL 7 without issue with a headless chrome agent.

I'm trying to set up a Windows 7 machine with an additional agent using the latest Chrome (64.0.3282.140 (Official Build) (64-bit))

I have installed all dependencies and the agent comes up cleanly. I've configured the browsers.ini at the agent and configured things correctly on the RHEL WPT side. WPT is seeing the agent.

When I run a test against this agent, it seems as though the agent is having trouble connecting to the Chrome websocket for debug info. I can confirm that Chrome is running on port 9222 but I get the orange screen and nothing more. In the debug log I see the following:

Code:
11:17:59.836 - Error Connecting to websocket_url: ws://localhost:9222/devtools/page/(XXXXXXXXXXXXXXXXXXXXXXXXXXXXX)
11:17:59.836 - Connect to dev tools websocket Error: [Errno 10061] No connection could be made because the target machine actively refused it
[code]

If I try to hit the "ws://localhost:9222" url after manually starting Chrome with remote debugging (similar to agent) I get this:

[code]
This site can’t be reached
The webpage at ws://localhost:9222/ might be temporarily down or it may have moved permanently to a new web address.
ERR_DISALLOWED_URL_SCHEME
[code]

Did something in chrome change?  Anyone else running into this issue.  Not finding much on google.  Thanks in advance!