WebPagetest Forums
Docker - Error submitting url for testing - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Docker - Error submitting url for testing (/showthread.php?tid=15436)



Docker - Error submitting url for testing - anjoy92 - 07-07-2018 01:39 AM

Hello,

I am trying to test the docker images on my local(mac) but have not been successful. Steps I took:

Created a docker network:
docker network create -d bridge my-bridge

Started the server image:
docker run -d -p 80:80 --network=my-bridge webpagetest/server:latest

Started the agent image:
docker run -d -e SERVER_URL="http://172.17.0.2/work/" -e LOCATION="docker_location" -e NAME="Docker_Test" --cap-add=NET_ADMIN --network=my-bridge webpagetest/agent:latest

Made changes to the location.ini:
[locations]
1=Docker_Test
default=Docker_Test

[Docker_Test]
1=docker_location
label="Local Docker Mac - State College"
group=Public

[docker_location]
browser=Chrome
label="Docker Local Mac State College - Chrome"
relayServer="172.18.0.3"

I am able to see that the agent is connected in the /install page but when I send a request the page says "Error submitting url for testing". I checked the folder permission in the server images, and the server has access to everything. I checked logs folder but it has nothing in it. Can anyone please help me with this. Thanks. I am planning to create a terraform script to run these images in Azure Container Instances. Will publish the scripts as soon am able to get this running.