WebPagetest Forums
TTFB = 0 when testing in Desktop. Mobile works fine - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: TTFB = 0 when testing in Desktop. Mobile works fine (/showthread.php?tid=15448)



TTFB = 0 when testing in Desktop. Mobile works fine - abhagupta - 07-21-2018 05:26 AM

Metric for TTFB is different in private instance when executed on mobile and Desktop.

My Script :

logData 0
navigate https://www.walmart.com/account/login
execAndWait document.querySelector('[name="email"]').value='webpagetest_10_items@gmail.com'
exec document.querySelector('[name=email]').dispatchEvent(new Event('blur'));
execAndWait document.querySelector('[name="password"]').value='XXXX';
exec document.querySelector('[name=password]').dispatchEvent(new Event('blur'));
execAndWait document.querySelector('[data-automation-id="signin-submit-btn"]').click()
sleep 10
logData 1
navigate https://www.walmart.com/cart

When I run the script in mobile device.. it gives me correct TTFB, but if I run it on Desktop (Chrome,FF, IE), it gives me TTFB of 0. Upon investigating HAR, it looks like I get TTFB of beacon.walmart.com instead of '/cart' .
Why would there be a difference in Desktop and Mobile.

One reference test for public instance of wpt of similar test https://www.webpagetest.org/result/180720_HQ_ee39d722c339b14f31c8b46399503ad8/1/details/

Any help in investigation is appreciated

Attaching 2 screenshots
Desktop[attachment=828]
Mobile[attachment=827]


RE: TTFB = 0 when testing in Desktop. Mobile works fine - abhagupta - 07-21-2018 07:06 AM

Update. If I add `combineSteps` in the beginning of the script, the I do get a reasonable TTFB (~400ms) in the desktop test.. Just wondering, why would `combineSteps` make any difference in how test is recorded.