WebPagetest Forums
WPTAgent not getting initiated - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: General Discussion (/forumdisplay.php?fid=25)
+--- Thread: WPTAgent not getting initiated (/showthread.php?tid=15698)



WPTAgent not getting initiated - sakthivel.vaithilingam - 03-05-2019 03:12 PM

I was using private instance and recently started migration to wptagent. Hosted in server perfectly with location configured as expected.

Installed all the requirements in WPT client as mentioned in 'https://github.com/WPO-Foundation/wptagent/blob/master/docs/install.md'

Using batch file to start WPTAgent but getting error, details below . Please help.

Batch File content:
cd C:\wpt_agent_sep2018\wptagent
call npm i -g lighthouse
FOR /L %%x IN (1, 1, 24) DO (
python.exe C:\wpt_agent_sep2018\wptagent\wptagent.py -vvvv --server "http://<<ipaddress>>:8081/work/" --location PT_Team_WPTDriver
)

Error Details :
Traceback (most recent call last):
File "C:\wpt_agent_sep2018\wptagent\wptagent.py", line 705, in <module>
main()
File "C:\wpt_agent_sep2018\wptagent\wptagent.py", line 692, in main
browsers = find_browsers()
File "C:\wpt_agent_sep2018\wptagent\wptagent.py", line 465, in find_browsers
build = get_windows_build()
File "C:\wpt_agent_sep2018\wptagent\wptagent.py", line 395, in get_windows_build
return int(output.strip().split(' ')[-1])
ValueError: invalid literal for int() with base 10: ''


RE: WPTAgent not getting initiated - sakthivel.vaithilingam - 03-07-2019 08:23 PM

Hi,

The above issue been resolved after installing Python3.7 with all modules as mentioned in https://github.com/WPO-Foundation/wptagent/blob/master/docs/install.md

Now getting parser.add_argument('--fps', type=int, choices=xrange(1, 61), default=10,
NameError: name 'xrange' is not defined

Whether WPTAgent compatible with Python3.7?

Please suggest.