WebPagetest Forums
woff font file request returned 404 before refetched properly - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: woff font file request returned 404 before refetched properly (/showthread.php?tid=15707)



woff font file request returned 404 before refetched properly - woshibt - 03-07-2019 03:54 PM

As you may see in the following test: https://www.webpagetest.org/result/190227_7Q_6d5605d1a6a34d93fcc1497a3cebeb35/1/details/#waterfall_view_step1, the request for .woff2 font files failed with 404 in the first try. Whereas, the later retry succeeded.

However, the waterfall for the same page when browsing in browser (like Chrome) showed no 404 errors for the .woff2 font files.

Can anyone shed some light on this behavior? Is it particular to WPT?

(Our page and resources are behind Akamai. Not sure if that could be an impact?)


RE: woff font file request returned 404 before refetched properly - pmeenan - 03-07-2019 11:02 PM

What later try? I see a request for a .woff (no 2) that succeeds but the .woff2 requests both fail with a 404. Those are different font files though.


RE: woff font file request returned 404 before refetched properly - woshibt - 03-08-2019 05:22 AM

Sorry. I did not make myself clear. There was not retry for the same font files. You are right. The later try fetched .woff font files.

Still, I wonder why the request for .woff2 files failed? The files actually exist. Any idea? Thank you!


RE: woff font file request returned 404 before refetched properly - pmeenan - 03-08-2019 05:53 AM

Maybe try purging the Akamai cache? The 404 responses have a cache-control header that makes them cacheable for a year. It's possible that the 404 is cached in Akamai (or somewhere else on the path).


RE: woff font file request returned 404 before refetched properly - pmeenan - 03-08-2019 05:55 AM

Testing from the US doesn't 404 the font files so my guess is the 404 is cached in some of Akamai's edges and a global purge should clear it (or at least a URL purge for those files but a global purge may be safer): https://www.webpagetest.org/result/190307_TM_a9e4d4f7b5eab3cceccdd9e1c8bdaf23/1/details/#waterfall_view_step1


RE: woff font file request returned 404 before refetched properly - pmeenan - 03-08-2019 05:56 AM

Eh, looks like it may have cleaned itself up. Here is from India: https://www.webpagetest.org/result/190307_9S_7489759a6d84adcbd72fb34cd3de99b9/1/details/#waterfall_view_step1