WebPagetest Forums
Upgrading to version 19.04 - PHP syntax error page__data.inc - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Upgrading to version 19.04 - PHP syntax error page__data.inc (/showthread.php?tid=15804)



Upgrading to version 19.04 - PHP syntax error page__data.inc - natedelgado - 06-06-2019 01:51 AM

I've had a stable version of webpagetest running for 2 years now. Currently the server runs version 17.12. Using the same method to build a server using 19.04 yields this error in the apache logs - PHP Parse error: syntax error, unexpected '[' in /var/www/html/webpagetest/www/page_data.inc on line 481.

Having a hard time finding a solution. Have any of the dependancies changed?

Thanks in advance.


RE: Upgrading to version 19.04 - PHP syntax error page__data.inc - vincent - 06-07-2019 04:42 AM

Looks like it has to do with the new heroTimings feature. What version of PHP are you on?