WebPagetest Forums
Webpage test user agent string missed to handle one of user agent string - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Bugs/Issues (/forumdisplay.php?fid=10)
+--- Thread: Webpage test user agent string missed to handle one of user agent string (/showthread.php?tid=15998)



Webpage test user agent string missed to handle one of user agent string - pmohite@ancestry.com - 03-09-2020 04:36 PM

Hi team.
we see webpagetest is not passing User agent string correctly for one of my page
https://www.ancestry.com/cs/offers/freetrial

for this page deksktop and mobile view is different .
mobile view is correct when actually renderred by real mobile device or chrome lighthouse audit .

but when simulated using wpt test , its using different user agent string.

I understand that by passing custom user agent string we can make this work (which is actually working ), but i think instead of bypassing what actual user using User agent just to get our desired results will not be right approach.

so please consider this as an defect


wrong view :
https://www.webpagetest.org/result/200309_3K_286874b830ba0e28431dd17e57ff46b1/

(user agent : Mozilla/5.0 (Linux; Android 4.4.4; Nexus 7 Build/KTU84P) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.146 Mobile Safari/537.36 PTST/200226.180231)

correct view :

https://www.webpagetest.org/result/200309_13_abd42583f9a5bd614dafe5e704caa75a/

(user agent : Mozilla/5.0 (Linux; Android 6.0.1; Nexus 5 Build/MRA58N) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3694.0 Mobile Safari/537.36 Chrome-Lighthouse PTST/200226.18023)