WebPagetest Forums
connection dropped with error 400 and 483 - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: connection dropped with error 400 and 483 (/showthread.php?tid=16086)



connection dropped with error 400 and 483 - bhanudbds - 06-05-2020 07:03 PM

Hi,
I am trying to setup WPT private agent in Heroku and connect it to the SpeedCurve WPT server.
But my connection is resetting again and again with the connection being dropped for every request to get work.

I am using the following Procfile:
Code:
worker: python /wptagent/wptagent.py --server "http://wpt1.speedcurve.com:443/work/" --location "salesforce-01" --xvfb --dockerized -vvvvv --shaper none --log wptagent.log

the logs are:
Code:
2020-06-05T08:32:46.630524+00:00 app[worker.1]: 08:32:46.630 - Resetting dropped connection: wpt1.speedcurve.com
2020-06-05T08:32:46.680104+00:00 app[worker.1]: 08:32:46.679 - http://wpt1.speedcurve.com:443 "GET /work/getwork.php?f=json&shards=1&reboot=1&location=salesforce-01&pc=80c436cd-a219-488f-8f75-d1a41ddd2a30&version=20.05&screenwidth=1920&screenheight=1200&freedisk=280.525&upminutes=9375 HTTP/1.1" 400 483
2020-06-05T08:32:51.685459+00:00 app[worker.1]: 08:32:51.685 - Checking for work: http://wpt1.speedcurve.com:443/work/getwork.php?f=json&shards=1&reboot=1&location=salesforce-01&pc=80c436cd-a219-488f-8f75-d1a41ddd2a30&version=20.05&screenwidth=1920&screenheight=1200&freedisk=280.184&upminutes=9375
2020-06-05T08:32:51.689853+00:00 app[worker.1]: 08:32:51.689 - Resetting dropped connection: wpt1.speedcurve.com
2020-06-05T08:32:51.743565+00:00 app[worker.1]: 08:32:51.743 - http://wpt1.speedcurve.com:443 "GET /work/getwork.php?f=json&shards=1&reboot=1&location=salesforce-01&pc=80c436cd-a219-488f-8f75-d1a41ddd2a30&version=20.05&screenwidth=1920&screenheight=1200&freedisk=280.184&upminutes=9375 HTTP/1.1" 400 483
2020-06-05T08:32:56.748746+00:00 app[worker.1]: 08:32:56.748 - Checking for work: http://wpt1.speedcurve.com:443/work/getwork.php?f=json&shards=1&reboot=1&location=salesforce-01&pc=80c436cd-a219-488f-8f75-d1a41ddd2a30&version=20.05&screenwidth=1920&screenheight=1200&freedisk=280.264&upminutes=9375

Here 483 probably represent 'Too many hops.' but I don't know how to increase the max no of hops.
Also, whats the right way to debug it?


RE: connection dropped with error 400 and 483 - pmeenan - 06-06-2020 12:00 AM

You should reach out to speedcurve directly and ask them. My guess, since it is port 443 that the URL should be https instead of http but they'd be the ones to ask.


RE: connection dropped with error 400 and 483 - bhanudbds - 06-11-2020 01:20 PM

Thanks for the reply Patrick.
Any ideas on how to enable traffic shaping on heroku?


RE: connection dropped with error 400 and 483 - pmeenan - 06-11-2020 10:42 PM

I doubt you can. I don't think heroku offers full VM's, just some form of containers and those don't give you full access to the networking stack.


RE: connection dropped with error 400 and 483 - bhanudbds - 06-11-2020 11:41 PM

Thanks Patrick.