WebPagetest Forums
Confused between lighthouse and WPT - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: Web Performance (/forumdisplay.php?fid=3)
+--- Forum: Discuss Test Results (/forumdisplay.php?fid=4)
+--- Thread: Confused between lighthouse and WPT (/showthread.php?tid=16148)



Confused between lighthouse and WPT - Cymru - 07-23-2020 04:10 AM

Hello All,

I've been working hard on my website and I am getting different results. On the lighthouse plugin with Chrome Browser, I get zero CLS but on the WPT report I am showing a CLS of 0.76. The test was run using Dulles, VA - Chrome - Emulated Nexus 5 - 3GFast - Mobile. Any ideas why I get this difference between the two?

Here is my WPT and lighthouse metrics are attached; https://webpagetest.org/result/200722_5V_3e734f34459e6b63c0cd81494bf8f89a/

Thanks in advance.


RE: Confused between lighthouse and WPT - pmeenan - 07-23-2020 05:17 AM

Looks like it is timing sensitive on when different bits rendered but I captured it with the raw video off of the device: https://www.webpagetest.org/getfile.php?test=200722_SJ_e35cda4185a7e4333f1fb3dbf08cbab6&file=1_video.mp4

The phone number at the top shifts slightly when the phone icon next to it renders (6 seconds into the video)


RE: Confused between lighthouse and WPT - Cymru - 07-23-2020 06:36 AM

Cheers Patrick. Really appreciate that mate. I think that is the icon that pushes the phone number around. Will get that sorted. Thank you. I guess I really dont understand why lighthouse on the browser doesn't see that.


RE: Confused between lighthouse and WPT - Cymru - 07-23-2020 11:30 PM

Well this is very confusing. I think we fixed the telephone number bit but I still get different scores at different times. I don't know at this point whether to just give up and say I am happy or keep on chasing.

https://webpagetest.org/result/200723_AX_9db75d31a9aa1b9d7082def1c6a90e41/
https://webpagetest.org/result/200723_FW_af0354d9efbd76e97f5ee22f81ca3a52/

I guess it could just be a timing issue on the rendering. That's the only thing that makes sense.