WebPagetest Forums
I can't see PageSpeed - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: I can't see PageSpeed (/showthread.php?tid=398)



I can't see PageSpeed - gyuseong - 10-08-2010 10:54 AM

Hello Patrick!

Thanks about new update ^^

There are two problems.

I have update 2.0 ver. but i can't see PageSpeed feature. (capture image 1)

and Label encoding Cracked in Test History page (capture 2)

I hope your answer.

Thanks.
Gyuseong
Encoding problem has solved.
I set AddDefaultCharset in http.config ^^


RE: I can't see PageSpeed - pmeenan - 10-08-2010 11:47 AM

Did you update the files on the test machine as well (urlblast, pagetest.dll, pagetest.exe)? The UI will only display the Page Speed results if it was captured at the time of the test and it is done on the test machine.

Thanks,

-Pat


RE: I can't see PageSpeed - gyuseong - 10-11-2010 01:23 PM

I can see pagespeed UI!!
but result page return 404 status code.
http://XXXXXXXXX/result/101010_4T/1/pagespeed/

------server makes result text file------------
../content/results/10/10/10/4T

1_Cached_IEWPG.txt 1_optimization.png.250.thm
1_Cached_IEWTR.txt 1_optimization.txt
1_Cached_optimization.png.250.thm 1_pagespeed.txt
1_Cached_optimization.txt 1_progress.csv
1_Cached_pagespeed.txt 1_report.txt
1_Cached_progress.csv 1_screen.jpg
1_Cached_report.txt 1_screen.jpg.250.thm
1_Cached_screen.jpg 1_screen.jpg.930.thm
1_Cached_screen.jpg.250.thm 1_screen_doc.jpg
1_Cached_screen_doc.jpg 1_screen_render.jpg
1_Cached_screen_render.jpg 1_waterfall.png.250.thm
1_Cached_waterfall.png.250.thm testinfo.ini
1_IEWPG.txt testinfo.json
1_IEWTR.txt url.txt

-------server apache error code -------
[Mon Oct 11 12:21:44 2010] [error] [client OO.OO.OO.OO] File does not exist: /usr/local/tomcat6/webapps/ROOT/wpt/content/result

help me patrick ㅜㅜ


RE: I can't see PageSpeed - pmeenan - 10-12-2010 03:48 AM

Does your .htaccess file have a rewrite rule for pagespeed? :

RewriteRule ^result/([a-zA-Z0-9_]+)/([0-9]+)/pagespeed/$ /pagespeed.php?test=$1&run=$2
RewriteRule ^result/([a-zA-Z0-9_]+)/([0-9]+)/pagespeed/cached/$ /pagespeed.php?test=$1&run=$2&cached=1

It should have been included in the release but if you were hand merging it's possible it got missed (or I missed putting it in the release).


RE: I can't see PageSpeed - gyuseong - 10-12-2010 09:05 PM

Oh! It works!

Thanks Patrick!

---------
..
#wiki
RewriteRule ^docs/(.*)$ /wiki/index.php?title=$1 [PT,L,QSA]
RewriteRule ^docs/*$ /wiki/index.php [L,QSA]

#pagespeed
RewriteRule ^result/([a-zA-Z0-9_]+)/([0-9]+)/pagespeed/$ /pagespeed.php?test=$1&run=$2
RewriteRule ^result/([a-zA-Z0-9_]+)/([0-9]+)/pagespeed/cached/$ /pagespeed.php?test=$1&run=$2&cached=1

#
#Caching for images
#
ExpiresActive On
ExpiresByType image/gif A31536000
..

-------------