WebPagetest Forums
Time Zone - Printable Version

+- WebPagetest Forums (https://www.webpagetest.org/forums)
+-- Forum: WebPagetest (/forumdisplay.php?fid=7)
+--- Forum: Private Instances (/forumdisplay.php?fid=12)
+--- Thread: Time Zone (/showthread.php?tid=720)



Time Zone - jbouressa@homeaway.com - 05-04-2011 08:02 AM

The page_data.csv file has the time that the test agent thinks it ran the test, but it doesn't include any time zone info. Is there a way to get the time zone of a test agent?

Also, the web server is hard-coded to EST. Is there any chance of having that become either dynamic or configurable?

Thanks,
James.


RE: Time Zone - pmeenan - 05-04-2011 08:30 AM

Actually, the web server runs on UTC and tries to figure out your time zone based on a javascript cookie. Where are you seeing EST results in the UI?

I'll see if there's anything I can do to override the times in the CSV with the UTC time that the test started.


RE: Time Zone - pmeenan - 05-04-2011 08:30 AM

Sorry, just realized this is in the hosted forum :-) The release I cut this week will have the dynamic timezone info (it's on the production server and in SVN).


RE: Time Zone - jbouressa@homeaway.com - 05-04-2011 08:44 AM

That would be fantastic, thank you.

I'm just migrating us to 2.x, and I have to tell you it's so much nicer having the web server on Linux and the wonderful REST API you've put together.

Great job, and thank you very much for providing this software,
James.


RE: Time Zone - ash - 05-08-2014 06:19 PM

Hi

Apparently i found some inconsistency. When agent timezone is set to anything different from UTC the timestamp reported in XML result ($xml->data->run->firstView->results->date) is wrong. Probably because the time saved in 1_IEWPG.txt file is saved as local agent time. As far as I correctly debugged this :-)

This is a problem because any automated tool that fetches test results from WPT Server is unaware of agent timezone that can change.


RE: Time Zone - pmeenan - 05-15-2014 12:46 AM

Do you happen to know if it was urlblast or wptdriver agent? The agents should use GMTime for everything and not write anything in local time so I'd like to fix that if I can track it down.


RE: Time Zone - ash - 05-15-2014 12:58 AM

Hi,

I use urlBlast.


RE: Time Zone - pmeenan - 05-15-2014 05:40 AM

Thx - that was an easy fix: https://github.com/WPO-Foundation/webpagetest/commit/b9e089c4b8b5d4e4ae85e15c457aa0e51b173e44

It'll be included in the next agent build which should be within a week or so (adding support for extracting arbitrary metrics from the page using js).