Current time: 04-08-2020, 06:58 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Assets on CDN getting status code 12031 from Dulles testing location
08-24-2012, 05:06 AM
Post: #1
Assets on CDN getting status code 12031 from Dulles testing location
Greetings, I've been trying to track down an issue with where by some assets that are located on a CDN are consistently returning a status code of 12031 (internet connection reset) in reports run from the Dulles, VA testing location. Here is a sample report.

http://www.webpagetest.org/result/120823...1/details/

I'm not getting the error from any other testing location around the world. The CDN company (level 3) says that their servers are all running properly. Any chance that there could be something anomalous with the Dulles WPT servers? The issue has been happening since last Friday morning.

Regards,

Tim
Find all posts by this user
Quote this message in a reply
08-27-2012, 10:23 PM
Post: #2
RE: Assets on CDN getting status code 12031 from Dulles testing location
I'm 99+% sure it's not a problem on the end of the Dulles agents but anything is possible. Dulles is the main test location and 90+% of the tests that go through WebPagetest go through Dulles and I haven't seen a similar issue show up anywhere else.

Every time I have seen a problem with a CDN that only shows up in one location it has always been a problem with the one edge note that serves the area where the problem is showing up. It could be a peering issue with the CDN provider and the test network (Verizon FIOS in the case of Dulles) or a problem with the edge node itself.

I'd be happy to help them debug it if you want to send them my way. I have full access to the Dulles location and can pretty much do any sort of test they'd want to see.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-28-2012, 03:12 AM
Post: #3
RE: Assets on CDN getting status code 12031 from Dulles testing location
Thanks, Pat. After a week and a half the issues seems to have resolved itself. Isn't that just how things seem to work out?
Find all posts by this user
Quote this message in a reply
08-28-2012, 05:02 AM
Post: #4
RE: Assets on CDN getting status code 12031 from Dulles testing location
Yep. Usually... It's unfortunate that there isn't more transparency but it could have been anywhere from peering to a problematic edge node.

It's a little disconcerting that there was a problem for a week before it fixed itself though. If it is a common issue and it just happened to get caught in this location because you were running testing then who knows how often it happens across the globe.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)