Current time: 09-20-2019, 04:53 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Locations / wptdriver Configuration Help
08-14-2014, 05:01 AM
Post: #1
Locations / wptdriver Configuration Help
I'm having a hard time configuring my locations.ini and wptdriver.ini files. Here is what I currently have:

wptdriver.ini
Code:
[WebPageTest]
    url=http://webpagetest.example.com/
    location=Virginia_wptdriver
    browser=Chrome,Firefox,IE
    Time Limit=120
    key=secret123
    ;Automatically install and update support software (Flash, Silverlight, etc)
    software=http://www.webpagetest.org/installers/software.dat
    
    [Chrome]
    exe="C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"
    options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
    installer=http://www.webpagetest.org/installers/browsers/chrome.dat
    
    [Firefox]
    exe="C:\Program Files (x86)\Mozilla Firefox\firefox.exe"
    options='-profile "%PROFILE%" -no-remote'
    installer=http://www.webpagetest.org/installers/browsers/firefox.dat
    template=firefox
    
    ;[Safari]
    ;exe="C:\Program Files\Safari\Safari.exe"
    
    [IE]
    exe="C:\Program Files\Internet Explorer\iexplore.exe"

locations.ini
Code:
[locations]
    1=IAD
    default=IAD
    
    
    
    ;
    ; These are the top-level locations that are listed in the location dropdown
    ; Each one points to one or more browser configurations
    ;
    [IAD]
    1=Virginia_wptdriver
    label=Virginia
    group=USA
    connectivity=LAN
    
    
    ;[Public_Dulles]
    ;1=WPT_Dulles_IE8
    ;label="WebPagetest.org - Dulles, VA"
    ;group=Public
    
    ;
    ; These are the browser-specific configurations that match the configurations
    ; defined in the top-level locations.  Each one of these MUST match the location
    ; name configured on the test agent (urlblast.ini or wptdriver.ini)
    ;
    
    ;[IE]
    ;browser=IE 8
    ;latency=0
    ;label="Test Location - IE 8"
    ;browserExe=pagetest.exe
    ;key=TestKey123
    
    
    [Virginia_wptdriver]
    browser=Chrome,Firefox,IE
    label="Chrome,Firefox,IE"
    key=secret123
    
    
    ;
    ; For a wptdriver configuration (chrome, firefox), the browser labels here
    ; MUST match the labels used in wptdriver.ini
    ;
    
    ;[Test]
    ;browser=Chrome,Firefox
    ;label="Test Location"

I'm seeing a GET request hitting the web server, so it seems everything is functioning correctly, except for the configuration.

Code:
/work/getwork.php?shards=1&location=Virginia_wptdriver&key=secret123&software=wpt&version=2.15.0.183&ver=183&pc=COMPUTERNAME&dns=69.20.0.164-69.20.0.196&freedisk=17.036&GPU=0

Any ideas?
Find all posts by this user
Quote this message in a reply
08-15-2014, 01:39 AM
Post: #2
RE: Locations / wptdriver Configuration Help
I figured this one out, and I wanted to share so everyone would benefit.

My secret key had an '&' character in it, and it was breaking the request made by the wptdriver software. Removing this character allowed it to connect.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)