Current time: 08-22-2019, 09:12 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with private instance - IE11 not working
11-18-2015, 11:00 AM
Post: #1
Problem with private instance - IE11 not working
I'm having a problem with a private instance:
- VirtualBox running XAMPP and Windows 7
- Apache2 as a service
- webpagetest_2.18

Firefox and Chrome work fine, IE 11 opens but never does anything. It just sits there on "about:blank" then the VM reboots.

Here are my config files - mostly taken from Andy Davies tutorial.

Can anyone spot what's going wrong?

Thanks, Tim

locations.ini
Code:
[locations]
1=Local
2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local

[Public_Dulles]
1=WPT_Dulles_IE8
label="WebPagetest.org - Dulles, VA"
group=Public

; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations.  Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)


; These are the browser-specific configurations that match the configurations
; defined in the top-level locations.  Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)

[Local-URLBlast]
browser=IE 11
latency=0
label="Local - IE 11"
[b]connectivity=LAN[/b]
;browserExe=pagetest.exe
;key=TestKey123

; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini

[Local-WPTDriver]
browser=Chrome,Firefox
label="Local"
connectivity=LAN

; This is an exaple of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance.  The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
;
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
;
; To use the public webpagetest.org instance you will need an API key

[WPT_Dulles_IE8]
browser=IE 11
label="WebPagetest.org Dulles, VA - IE8"
relayServer="http://www.webpagetest.org/"
relayKey=<your API key>
relayLocation=Dulles_IE8

urlblast.ini
Code:
[Configuration]
Startup Delay=30
Log File=c:\webpagetest\agent\urlblast
Timeout=120
use current account=1

; Where to get work from
Url Files Url=http://127.0.0.1/work/
Location=Local-URLBlast
;Location Key=TestKey123

wptdriver.ini
Code:
[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=chrome
Time Limit=120
;key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
#software=http://www.webpagetest.org/installers/software.dat
software=http://127.0.0.1/installers/software.dat

[chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://127.0.0.1/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://127.0.0.1/installers/browsers/firefox.dat
template=firefox

[Safari]
exe="C:\Program Files\Safari\Safari.exe"

[IE]
exe="C:\Program Files\Internet Explorer\iexplore.exe"

Code:
WebPagetest 2.18 Installation Check
PHP

    PHP version at least 5.3: 5.6.14
    GD Module Installed: yes
    FreeType enabled for GD (required for video rendering): yes
    zip Module Installed: yes
    zlib Module Installed: yes
    curl Module Installed: yes
    php.ini allow_url_fopen enabled: yes
    APC Installed: NO (optional)
    SQLite Installed (for editable test labels): yes
    Open SSL Module Installed (for "Login with Google"): yes
    php.ini upload_max_filesize > 10MB: 2M (optional)
    php.ini post_max_size > 10MB: 8M (optional)
    php.ini memory_limit > 256MB or -1 (disabled): 128M (optional)

System Utilities

    ffmpeg Installed with --enable-libx264 (required for video): yes
    ffmpeg Installed with scale and decimate filters(required for mobile video): N-76684-g1fe82ab,scale,mpdecimate
    imagemagick compare Installed (required for mobile video): NO (optional)
    jpegtran Installed (required for JPEG Analysis): yes
    exiftool Installed (required for JPEG Analysis): NO (optional)

Misc

    python 2.7 with modules (faster mobile video processing): Error running "python video/visualmetrics.py -c" (optional)

Filesystem

    {docroot}/tmp writable: yes
    {docroot}/dat writable: yes
    {docroot}/results writable: yes
    {docroot}/work/jobs writable: yes
    {docroot}/work/video writable: yes
    {docroot}/logs writable: yes

Test Locations

    Local : Local
        Local-URLBlast : Local - IE 11 - 1 agents connected
        Local-WPTDriver : Local - 1 agents connected
    Public_Dulles : WebPagetest.org - Dulles, VA
        WPT_Dulles_IE8 : WebPagetest.org Dulles, VA - IE8 - No Agents Connected
Find all posts by this user
Quote this message in a reply
11-19-2015, 07:35 PM
Post: #2
RE: Problem with private instance - IE11 not working
IE11 is driven using wptdriver so you don't need urlblast any longer

So in locations.ini remove the Local-URLBlast section and add IE to the list of browsers in the Local-WPTDriver section

I'll update the blog post at some point in the near future

Andy

Using WebPageTest - http://usingwpt.com/
Visit this user's website Find all posts by this user
Quote this message in a reply
11-20-2015, 05:53 AM
Post: #3
RE: Problem with private instance - IE11 not working
Thanks Andy Smile Here are my latest files - IE11 opens but it doesn't do anything - just sits there with a blank page, so no change. I've rebooted to make sure changes are applied. Chrome/Firefox still work fine. Any ideas?

locations.ini
Code:
[locations]
1=Local
2=Public_Dulles
default=Test_loc

;
; These are the top-level locations that are listed in the location dropdown
; Each one points to one or more browser configurations
;

[Local]
;1=Local-URLBlast
1=Local-WPTDriver
label=Local

[Public_Dulles]
1=WPT_Dulles_IE8
label="WebPagetest.org - Dulles, VA"
group=Public


;
; Tese are the browser-specific configurations that match the configurations
; defined in the top-level locations.  Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

;
; These are the browser-specific configurations that match the configurations
; defined in the top-level locations.  Each one of these MUST match the location
; name configured on the test agent (urlblast.ini or wptdriver.ini)
;

;[Local-URLBlast]
;browser=IE 11
;latency=0
;label="Local - IE 11"
;connectivity=LAN
;browserExe=pagetest.exe
;key=TestKey123

;
; For a wptdriver configuration (chrome, firefox), the browser labels here
; MUST match the labels used in wptdriver.ini
;

[Local-WPTDriver]
browser=Chrome,Firefox,IE11
label="Local"
connectivity=LAN


;
; This is an exaple of a "remote" configuration where tests can be proxied to a remote
; webpagetest instance.  The test will be run by the remote server but the results
; will be downloaded to the local server and deleted from the remote agent
;
; Each location that you want to use from the remote server needs to be configured
; individually on the local configuration (location names do not need to match)
;
; To use the public webpagetest.org instance you will need an API key
;

[WPT_Dulles_IE8]
browser=IE 11
label="WebPagetest.org Dulles, VA - IE8"
relayServer="http://www.webpagetest.org/"
relayKey=<your API key>
relayLocation=Dulles_IE8

wptdriver.ini
Code:
[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=chrome
Time Limit=120
;key=TestKey123
;Automatically install and update support software (Flash, Silverlight, etc)
#software=http://www.webpagetest.org/installers/software.dat
software=http://127.0.0.1/installers/software.dat

[chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://127.0.0.1/installers/browsers/chrome.dat

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%PROFILE%" -no-remote'
installer=http://127.0.0.1/installers/browsers/firefox.dat
template=firefox

[Safari]
exe="C:\Program Files\Safari\Safari.exe"

[IE]
exe="C:\Program Files\Internet Explorer\iexplore.exe"

[IE11]
exe="C:\Program Files\Internet Explorer\iexplore.exe"
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)