Current time: 06-19-2019, 02:55 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 1 Vote(s) - 1 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TimeToFirstByte value between Pingdom & WebPageTest
12-15-2018, 06:07 PM
Post: #1
TimeToFirstByte value between Pingdom & WebPageTest
Hey There!

If we do a speedtest on your site for our website (http://www.hello-world.net) WebPageTest always reporting TTFB values with round about 300ms.

You can see it here:
https://www.webpagetest.org/result/18121...98f9f1231/


If we do a speedtest with Pingdom we got always TTFB values between 1.700 - 2.500ms as you can see it here:

Pingdom: https://tools.pingdom.com/#59ec32dca3400000

We do not know which site is reporting the "right" value-range and which is wrong. Why are the TTFB values at your site so small and the Pindom values so big? Do you have different methods for messure the TTFB or what is the tecnical background for this effect?

thnx for helping in advance

best regards from Germany
Nico
Find all posts by this user
Quote this message in a reply
12-16-2018, 02:46 AM
Post: #2
RE: TimeToFirstByte value between Pingdom & WebPageTest
For starters, WebPageTest uses a traffic-shaped connection to behave more like a consumer Internet connection. In the case of your test with a "Cable" connection that means 28ms RTT added to the link. Looking at the actual socket connect time it looks like it's ~44ms RTT to the server (including the 28ms from the cable profile).

There are at least 4 round trips to request the HTML (DNS, socket connect, TLS negotiation and the request itself) which would take ~180ms under optimal conditions (the TLS negotiation took 77ms and the server response to the HTTP request took 124ms so there were additional delays).

Usually we see things the other way where pingdom is much faster because there is no traffic-shaping on their connection.

My guess is that there is some protection filtering in the path on your server that is rate-limiting pingdom (either by IP address or because of the connection itself). I'm not sure what browser engine they are using right now but last I heard it was something like Chrome 38 which didn't support HTTP/2 and uses older TLS ciphers. It's possible that is causing it to go down a slow path of some kind.

It could also be that the server has variable performance and the pingdom test hit it when all of the caches were cold but it looks to be consistently slow in pingdom and consistently fast in WebPageTest so I don't think that's it.

WebPageTest runs the current stable browsers and the results look consistent so I'm pretty confident that teh site itself is responding quickly. If you want to be sure you can add response timing to the access logs on the server or add something like Google Analytics which will report performance metrics from actual usage.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-16-2018, 07:14 PM
Post: #3
RE: TimeToFirstByte value between Pingdom & WebPageTest
Hi Patrick!

thnx for your fast and detailed reply. I think NOW we get a glue for further research. We will contact the hosting provider in the next step.

thnx and best regards from snow-coverd Germany
Nico
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)