Current time: 01-24-2021, 03:53 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird idle time in the Waterfall
12-15-2020, 07:35 AM (This post was last modified: 12-16-2020 01:01 AM by CamiloAPR.)
Post: #1
Weird idle time in the Waterfall
Hey everyone. So a couple of weeks ago I was running some tests on WebPageTest, Pingdom and Google Pagespeed Insights to get a general sense of a site's performance. Got relatively normal results on all of them but WebPageTest. on WebPageTest I kept noticing weird idle times between requests. but nothing I've seen before, they were really long idle times. last week I noticed those idle times were gone, but I'm pretty sure they weren't server/code related, as I noticed several sites were getting the same thing. Here's an example:

Result from Nov 24th -> https://i.imgur.com/7ZEWACe.png
Result from Dec 10th -> https://i.imgur.com/6lD28HU.png



Does anyone have a clue about this?, I can't help but think it may have been an issue in WebPageTest (As I said, no other tool had this issue).
Find all posts by this user
Quote this message in a reply
12-15-2020, 11:43 PM
Post: #2
RE: Weird idle time in the Waterfall
Do you have links to the test results themselves (can email them to pmeenan@webpagetest.org if you don't want them public)?

The CPU line looks pretty busy at the time so it looks like there was something non-request-based going on (layout would be my guess).

Given the dates and location of the gaps, if the test location was Dulles, I am going to bet it was this: https://github.com/WPO-Foundation/webpag...ssues/1410

Chrome on Ubuntu 20.04 was having some pathological layout times with some sites so the Dulles agents were re-deployed with 18.04 until I can track down what is going on.
Visit this user's website Find all posts by this user
Quote this message in a reply
12-16-2020, 01:00 AM
Post: #3
RE: Weird idle time in the Waterfall
Thanks for the quick reply!. Yeah. Looks like that might be it. is there something we should keep in mind going forward to avoid this issue?
Find all posts by this user
Quote this message in a reply
12-16-2020, 01:20 AM
Post: #4
RE: Weird idle time in the Waterfall
As users you shouldn't have to worry about it now that we're aware it's a problem. Any OS updates in the future now have a decent number of test sites that demonstrate the problem to use for testing before deploying and it won't be deployed if there are issues.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)