Current time: 04-10-2020, 07:12 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
wpt stops measuring before page is fully loaded
07-10-2013, 12:08 PM (This post was last modified: 07-10-2013 12:14 PM by Stephen.)
Post: #3
RE: wpt stops measuring before page is fully loaded
Thank you very much for your reply Patrick.

Once the pins are loaded, there will be an item whose id is "store_0". I have placed that item "id=store_0" into advanced setting tab, but when running the test, it still doesn't wait for that element to appear before finishing the test. http://www.webpagetest.org/result/130710_R8_3QY/
It's a bug of AUT that the pins will not appear in Firefox when you visit it first time, but the site under test is okay for this in IE8. http://www.webpagetest.org/result/130710_J9_3KN/ I expect my test can capture such issue.

Furthermore, I need to do another test involving several steps on this page for which I have to write script. I write it as below, but it doesn't look like working correctly. I'm not sure how I can force the measurement to the result page of statement "execAndWait document.querySelector("button.icon").click();" continuously measuring until the dom "id=store_0" appears.

logData 0
setEventName findStore
navigate http://global.ecco.com/en/service/find-a-store
setDOMElement id=storeSearch
setValue id=storeSearch Shanghai
logData 1
combineSteps
setEventName search
execAndWait document.querySelector("button.icon").click();
execAndWait $('#store_0').ready(function(){return;});
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: wpt stops measuring before page is fully loaded - Stephen - 07-10-2013 12:08 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)