MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Congestion Window issues
Current time: 09-26-2020, 12:13 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Congestion Window issues
09-04-2014, 11:43 PM
Post: #1
Congestion Window issues
Hi there

I think it would be useful to surface potential congestion window issues for content downloads in the UI.

I have a report that is mostly 'green' in the top right area which is nice:
http://www.webpagetest.org/result/140903_Y8_17TS/

However, on closer inspection I felt that some of the images were taking longer than would have been expected.

Specifically: http://www.webpagetest.org/result/140903...9/details/

and this infor from waterfall view:
URL: http://s.games.iwin.com/m/alex_harrison/...banner.jpg
Content Download: 352 ms
Bytes In (downloaded): 29.9 KB

To troubleshoot this I ran again with tcpdump and then parsed the tcpdump for this request (on port 53859) within cloudshark.
https://www.cloudshark.org/captures/a0ef...3D%3D53859

I was initially expecting to see errors but what I saw was repeated two TCP segments being delivered and then an ACK which strikes me as a really low congestion window setting.

We're now following up with the relevant party to address this issue.

If WPT is calculating the download time then I imagine it might know how many segments are being delivered per ACK.

A value of 2 seems very low (compared to http://www.cdnplanet.com/blog/initcwnd-s...providers/) so it might be useful to surface this as a red / amber / green value.

Hope this helps,

Michael Ewins
mewins@iwin.com
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Congestion Window issues - ewinsmi - 09-04-2014 11:43 PM
RE: Congestion Window issues - ewinsmi - 09-06-2014, 12:57 AM
RE: Congestion Window issues - pmeenan - 09-11-2014, 12:06 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)