Current time: 10-26-2020, 09:02 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script works locally, not on agent
09-29-2014, 11:53 PM (This post was last modified: 10-02-2014 12:20 AM by RLilly.)
Post: #4
RE: Script works locally, not on agent
(09-27-2014 04:02 AM)mverkerk Wrote:  Hey RLilly! Thx for your response!
You're right, i should mentioned that i have been testing this with both IE11 and Chrome. On the local agent, i tested it in IE11 using pagetest plugin and it completes without any issues ...

Your script is a no-go for me ... it just gets stuck. Here is the log:

2014/09/26 17:00:17 - Test Created
2014/09/26 17:00:17 - Starting test (initiated by tester <agent>)
2014/09/26 17:08:53 - Test Run Complete. Run: 1, Cached: 0, Done: , Tester: <agent>

Notice the 8 minutes of ... nothing ...

i tried your script locally on one of my agents, using the pagetest plugin in IE and it worked perfectly!

That's the part that i don't get - why does it work locally using pagetest but not when submitted via wpt?

thanks for the help!


Huh... odd. Are you using a private/local instance of WPT or the public one? I was testing against a private instance. If you're using the public one, just to try something that will get a result, change the top logData parm to a '1'. ie:

logData 1
navigate https://www.godaddy.com
click innerHTML=Sign In
sleep 5
setValue id=loginname <masked>
setValue id=password <masked>
submitForm id=loginForm

When I did that on the public site, I ended up with this:

http://www.webpagetest.org/result/140929_XE_R00/

Give it a try with the correct info loaded. Following the filmstrip might help track down what's going on. It might also be worth noting that on a few of the tests, the login screen presented a Captcha challenge. Any chance you're bumping up against that when running the wpt version test? If it's not completing the login, that would explain the 8min timeout with no data reporting. Changing the logData value should let you see that.

Update: Actually, looks like I overlooked the fact that you were testing with IE11. In testing with that, I'm also experiencing a fail condition. In watching what happens, the script pulls down the login panel but doesn't seem to be able to populate the name and pw boxes. Haven't had time to try and figure out what's going on just yet.

Robert
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Script works locally, not on agent - RLilly - 09-29-2014 11:53 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)