MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
ClickAndWait not waiting long enough
Current time: 09-29-2020, 10:01 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ClickAndWait not waiting long enough
01-22-2016, 03:57 AM (This post was last modified: 01-22-2016 03:57 AM by DLee.)
Post: #1
ClickAndWait not waiting long enough
I am trying to measure the performance of a dashboard page. In order to do so, I need to login, get to an intermediate page, and upon button click be redirected to the dashboard page. I am using the below script.

logData 0
navigate [Login url]
setValue name=UserName [Username]
setValue name=Password [Password]
submitForm id=form
logData 1
clickAndWait id=button

The issue I am seeing is the target dashboard page is not fully loading and being captured in WebpageTest. It has a few AJAX calls/spinners on it that could take some time to finish. I don't see those calls being logged which it would do when the page normally finishes loading. What is happening on ClickAndWait is the page is doing a postback to itself then on server side redirects to the final page. I cannot refactor this now or find a way to set the login via cookies or injection. I am trying to get some performance data to build up a case to work on this page.

This script has finished beautifully before late at night when traffic was low for the site so I'm not sure why it doesn't work during normal business hours.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
ClickAndWait not waiting long enough - DLee - 01-22-2016 03:57 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)