MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
HAR file and HTTP2 - httpversion is wrong
Current time: 12-01-2020, 10:42 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HAR file and HTTP2 - httpversion is wrong
03-04-2016, 01:22 AM (This post was last modified: 03-04-2016 01:30 AM by shmilla.)
Post: #1
HAR file and HTTP2 - httpversion is wrong
If you export a HAR file from webpagetest for an HTTP2 site, there seems to be something weird with the response code. Or am I misinterpreting this?

Charles (RAW response view)
us: 200

Google HAR viewer shows response as:
200 OK us:

Opening the HAR as text or in jSON viewer I see
"HTTPVersion" : "US:" , shouldn't that be the HTTP version?

Just out of curiosity, how is the HAR supposed to show HTTP2? I exported a HAR from CHROME directly and it just shows:
"response": {
"status": 200,
"statusText": "OK",
"httpVersion": "unknown",i

Also, looking at another WPT Har export of an HTTP2 site, it looks like the HAR is missing the status text. Trivial since we have the code, but noticed the difference,so thought I'd mention it

Webpagetest HAR export of HTTP2 content:
"response": {
"status": 200,
"statusText": "",
....
"httpVersion": "us:",


CHROME HAR export of same page
"response": {
"status": 200,
"statusText": "OK",
"httpVersion": "unknown",
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
HAR file and HTTP2 - httpversion is wrong - shmilla - 03-04-2016 01:22 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)