Current time: 01-20-2021, 08:44 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script not executing or stopping too early
09-27-2016, 12:31 AM (This post was last modified: 09-27-2016 01:09 AM by maryb86.)
Post: #3
RE: Script not executing or stopping too early
(09-25-2016 12:22 AM)andydavies Wrote:  To ask the really dumb question…

Does this line work when you try it in DevTools?

Code:
document.querySelector('ha-flow-step[stepid="step0"] .ha-button-primary').click();

Also if you capture the response bodies, is that element in there (I came across a problem with another site where the WPT agent was getting a slightly different page to the one I tested against in my browser)

No idea on #2, I've not seen that happen before - might test it with one of my scripts

Thanks for taking a look Smile Yes it does work in dev tools. It doesn't seem to be a problem with the script itself, I think it's a bug with webpagetest to do with the order of using exec or execAndWait. I spent all afternoon Friday trying to figure out what the problem is and will try write up a new post that clearly spells it out.

Hm, I can't seem to get the bug down exactly. Here is what I have written down. Would be great if someone could take a look and comment on why this behaviour is happening:

Succeeded, completed all steps.
https://www.webpagetest.org/result/160923_4M_10K4/
logData 0
navigate http://www.yahoo.com
logData 1
setValue id=uh-search-box apple
navigate http://www.google.com

Failed, stopped after navigating to yahoo.com
https://www.webpagetest.org/result/160923_38_10E6/
logData 0
navigate http://www.yahoo.com
logData 1
execAndWait document.querySelector('#uh-search-box').value='apple’;
navigate http://www.google.com

Partially succeeded, failed to enter ‘apple'
https://www.webpagetest.org/result/160923_72_10KB/
logData 0
navigate http://www.yahoo.com
logData 1
exec document.querySelector('#uh-search-box').value='apple’;
navigate http://www.google.com
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: Script not executing or stopping too early - maryb86 - 09-27-2016 12:31 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)