Current time: 09-21-2017, 11:27 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Facing issues setting up WPT Private Instance on AWS
08-31-2017, 04:36 PM
Post: #1
Facing issues setting up WPT Private Instance on AWS
I am facing issues setting up WPT private Instance on AWS.

I am using this link as the guide
https://www.peterhedenskog.com/blog/2015...-instance/

I have gone mostly with the default settings as detailed in the article. The server is setup in Oregon using ami-d7bde6e7 and I went with the default t2.micro for it. Only the basic settings listed in the article were setup.

Quote:ec2_key=<yourkey>
ec2_secret=<yoursecret>
api_key=<yourOwnAPIKey>
headless=0
iq=80
pngss=1

Once the server was up and running, I am able to access the User interface and tried running a test in EU(London). The first test runs fine, but if I try doing a test again, it gets struck at the "Waiting at front of queue" screen and the result never comes.

Terminating the wpt agent instance helps sometimes as server launches a fresh instance to run the test.

Also one more thing that I noticed is that its sometimes launching the Linux ami in the same region along with windows even though I have only scheduled the test for the EU (London) which is windows.

I need a reliable setup as I want to integrate it with sitespeed for setting up a dashboard for continuous monitoring. Can someone help with the right AMIs, settings that I should be using for a reliable setup.

Does it help if I configure it to have one agent instance running all the time? But I need this only for London at the moment. Other regions are not relevant for me.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Facing issues setting up WPT Private Instance on AWS - Lord Nemesis - 08-31-2017 04:36 PM

Forum Jump:


User(s) browsing this thread: 2 Guest(s)