MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Adding Akamai Pragma headers breaks LCP reporting
Current time: 09-20-2020, 06:22 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Adding Akamai Pragma headers breaks LCP reporting
08-17-2020, 01:39 PM
Post: #1
Bug Adding Akamai Pragma headers breaks LCP reporting
Here are two tests I ran, one with Akamai headers and one without.

Akamai headers added - https://www.webpagetest.org/result/20081...f57a34772/

No headers - https://www.webpagetest.org/result/20081...9b6c655c5/

With Akamai headers, quite a few requests were not loaded and LCP wasn't reported. There are few more things, however the gist is same. The test doesn't work properly. For the record, these tests were scheduled using UI and headers were added under "Advanced > Custom headers". Here is the string that was provided by Akamai.
Code:
Pragma: akamai-x-cache-on, akamai-x-cache-remote-on, akamai-x-check-cacheable, akamai-x-get-cache-key, akamai-x-get-true-cache-key, akamai-x-get-extracted-values, akamai-x-get-ssl-client-session-id, akamai-x-serial-no, akamai-x-get-request-id


Link to Akamai Pragma Headers documentation: https://learn.akamai.com/en-us/webhelp/c...2DA43.html
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Adding Akamai Pragma headers breaks LCP reporting - kumarldh - 08-17-2020 01:39 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)