Current time: 12-15-2019, 12:26 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't seem to make any real dents in speed, seem to be going backwards
12-22-2011, 02:26 AM
Post: #1
Can't seem to make any real dents in speed, seem to be going backwards
Hello, I am pretty new to web development, and have been given the task of optimizing my non-profit camp's web page. Our recent test results are here:
http://www.webpagetest.org/result/111221_9E_2KMEB/

I've worked quite hard to try and figure this out by reading the forums and working with various plugins, but can't seem to make any increases in performance. I installed force gzip plugin, but my text compression still seems lousy. I've used w3 total cache, but I apparently fail to cache static images. I'm not sure how to optimize the use of that plugin, but I am sure that I am not doing it!

January is the biggest month for booking retreats, and I was hoping to have everything optimized both for my users and for the search engines by then, but after a week or so of plugging away it appears I may have even made things worse! I have no clue why the second load time of my site would be slower than the first if I am caching things, for instance!

Any and all help would be greatly appreciated...this is all so much more complicated than I anticipated!
Find all posts by this user
Quote this message in a reply
12-22-2011, 03:22 AM
Post: #2
RE: Can't seem to make any real dents in speed, seem to be going backwards
Couple of notes:

1 - It looks like your first byte times are really painful (2+ seconds). In W3TC settings, do you have "Page Cache" enabled? How about Object Cache and Database Cache? If so, are they configured for Disk?

2 - It looks like your css and images are not being cached by the browser. Do you have "Browser Cache" enabled in the W3TC settings?
Visit this user's website Find all posts by this user
Quote this message in a reply
12-22-2011, 03:41 AM (This post was last modified: 12-22-2011 03:42 AM by vanderkamp.)
Post: #3
RE: Can't seem to make any real dents in speed, seem to be going backwards
Hey Patrick! Thanks for responding.

I have all of those settings "enabled", and I disabled preview mode. Did I need to also "deploy" the settings from the preview? When I tried to do that, I kept getting error messages telling me to try again. All the settings I have are exactly as you describe, but nothing good seems to be coming of it. Does the plugin have a lag time before it actually impacts performance? I made these adjustments today.
Correction, it says, "Are you sure you want to do this?"

And then gives me a link to "please try again."
Find all posts by this user
Quote this message in a reply
12-22-2011, 03:47 AM
Post: #4
RE: Can't seem to make any real dents in speed, seem to be going backwards
When you installed the plugin, there were a few things you needed to do to the system first (permissions to a couple of directories and files I believe). Do you remember if you did that?

The changes should take effect immediately (though the cache needs to get primed by someone visiting the page so the very first visit after turning it on will still be slower).
Visit this user's website Find all posts by this user
Quote this message in a reply
12-22-2011, 03:51 AM
Post: #5
RE: Can't seem to make any real dents in speed, seem to be going backwards
I don't believe I did, no. I am not sure how to give permission to various directories. Do you think WP Super Cache is a better fit for me since I am not as booked up on the technical side of things?
Find all posts by this user
Quote this message in a reply
12-22-2011, 05:54 AM
Post: #6
RE: Can't seem to make any real dents in speed, seem to be going backwards
I think all of them will require a tweak to the server to give permissions to write to a cache directory. There is a "compatibility check" button at the top of the W3TC settings page that will check the state of everything and let you know if anything needs to be done.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)