Current time: 12-10-2019, 05:45 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Start Render Help
01-07-2012, 05:14 AM
Post: #1
Start Render Help
I was wondering if I could get some insight into the Start Render times and how they are reported through WebPagetest. Here's an example of our test results:

http://www.webpagetest.org/result/120106_34_2RW6A/

According to the results on our First View, the Start Render time is over 10.6 seconds. However, when I clear out my browser cache and access our site directly from my local browser, the whole page is loaded in about 2 seconds, similar to the Repeat View results.

Whenever I use WebPageTest at various locations around the world, the Start Render time is consistently around 10 seconds on First View and the Repeat View is similar to what I experience when using my own browser.

Any thoughts or suggestions? Thanks for your help.
Find all posts by this user
Quote this message in a reply
01-07-2012, 06:03 AM
Post: #2
RE: Start Render Help
How close is your local browser to the server (ping times)? If you are in the same state and on a high-speed Internet connection that could easily explain the difference. Most of the time is sucked up in making back and forth trips to request stuff from the server (the green and orange bars).

The default WebPagetest testing profile has 50ms of latency on the last mile (add to that the actual backbone time to your servers).
Visit this user's website Find all posts by this user
Quote this message in a reply
01-07-2012, 06:06 AM
Post: #3
RE: Start Render Help
(01-07-2012 06:03 AM)pmeenan Wrote:  How close is your local browser to the server (ping times)? If you are in the same state and on a high-speed Internet connection that could easily explain the difference. Most of the time is sucked up in making back and forth trips to request stuff from the server (the green and orange bars).

The default WebPagetest testing profile has 50ms of latency on the last mile (add to that the actual backbone time to your servers).

That makes sense. Also, when I take the default test criteria from webpagetest I am selecting a DSL connection where typically I have a faster connection locally. When I rerun the tests with a Cable connection, my results are more in line with what I experience on my browser.

Thanks for your help.
Find all posts by this user
Quote this message in a reply
01-07-2012, 06:09 AM
Post: #4
RE: Start Render Help
btw, the specific information you asked, about the start render times, is that WebPagetest instruments the API calls that the browser makes to draw to the screen and it inspects what the browser draws to see the first point in time when the browser draws something that isn't a solid color background.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)