Current time: 11-17-2019, 07:06 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HAR export - incorrect startedDateTime
03-16-2012, 06:50 PM
Post: #1
HAR export - incorrect startedDateTime
I noticed that "startedDateTime" values in the JSON HAR export are missing timestamp values which are required to generate nice waterfall views in HAR reader tools. Without this data the waterfalls are visually flat.

startedDateTime":"2012-03-16T07:39:28.000+00:00"
startedDateTime":"2012-03-16T07:39:38.000+00:00"

The applicable test result can be found here:
http://www.webpagetest.org/result/120316_ZQ_3KRWS/

Is this a bug? Or is the data not included on purpose?

Thanks in advance.
Find all posts by this user
Quote this message in a reply
03-17-2012, 12:16 AM
Post: #2
RE: HAR export - incorrect startedDateTime
It is a bug. I thought I had an issue open on it but someone must have mailed it to me. It's on my list of things to get fixed really soon (within the next week) : http://code.google.com/p/webpagetest/iss...tail?id=77
Visit this user's website Find all posts by this user
Quote this message in a reply
03-19-2012, 08:06 PM
Post: #3
RE: HAR export - incorrect startedDateTime
Great to have it fixed soon, thanks!
Find all posts by this user
Quote this message in a reply
03-20-2012, 03:32 AM
Post: #4
RE: HAR export - incorrect startedDateTime
ok, the times have been fixed - sorry about that (we had changed a variable name and missed updating it in one place). The online HAR viewer seems to be jumbling up the order of the requests (not sure why but I looked at the raw JSON and they are fine).

Let me know if you see anything else odd going on there.

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
03-26-2012, 07:13 PM
Post: #5
RE: HAR export - incorrect startedDateTime
Just checked the HAR output generated via this url: http://www.webpagetest.org/export.php?te...6_3R_3QH5T and the output still misses the relevant timestamp values.

Can you have a look please?
Thanks
Find all posts by this user
Quote this message in a reply
03-26-2012, 11:51 PM
Post: #6
RE: HAR export - incorrect startedDateTime
Any chance you are getting a cached version of the file from your browser? I just pulled it and loaded the result into the HAR viewer and got a waterfall. Looking at the first 4-5 requests in the raw JSON file look like they are correctly tracking the startedDateTime:

"startedDateTime":"2012-03-26T01:45:54.482+00:00"
"startedDateTime":"2012-03-26T01:45:55.334+00:00"
"startedDateTime":"2012-03-26T01:45:55.334+00:00"
"startedDateTime":"2012-03-26T01:45:55.800+00:00"
"startedDateTime":"2012-03-26T01:45:55.920+00:00"

Thanks,

-Pat
Visit this user's website Find all posts by this user
Quote this message in a reply
03-28-2012, 05:39 PM
Post: #7
RE: HAR export - incorrect startedDateTime
You are right, my HAR reader was fooling me Wink Har viewer is showing the right waterfall.

Thanks for the double check!
Find all posts by this user
Quote this message in a reply
04-10-2012, 08:23 PM
Post: #8
RE: HAR export - incorrect startedDateTime
Would this fix be available in hosted version? 2.6 has exactly the same issue.
Find all posts by this user
Quote this message in a reply
04-13-2012, 05:17 AM
Post: #9
RE: HAR export - incorrect startedDateTime
Yes, it will be in the next release or you can grab the fix from svn: http://webpagetest.googlecode.com/svn/tr...detail.inc

if you want to be even more surgical, you can just change 'offset' to 'load_start' in LoadRequests()
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)