Current time: 12-15-2019, 03:33 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
IE8 & IE9 Doc Complete Issue
11-07-2012, 01:54 AM
Post: #1
IE8 & IE9 Doc Complete Issue
Hi,

i´ve encountered different timing values for doc complete when measuring websides with video and without video.

in the first measurement with video enabled the doc complete state is set allthough not all images are completly load.
http://www.webpagetest.org/result/121106_M5_DPA/

the measurement without video sets doc complete at the right time, when all elements are loaded complete
http://www.webpagetest.org/result/121106_2K_DR3/

the difference is visible in the waterfall and the Doc Complete Requests

IE9 shows the same behaviour
without video
http://www.webpagetest.org/result/121106_88_E36/
with video
http://www.webpagetest.org/result/121106_3S_E31/

hope that somebody can help.

thanks & regards
Heiko
Find all posts by this user
Quote this message in a reply
11-08-2012, 08:38 AM
Post: #2
RE: IE8 & IE9 Doc Complete Issue
From the looks of it you may have some code that is altering the page and that is timing sensitive. The video capture may be changing the timing just enough to get it to happen on the other side of the onload event. If you look at where the favicon loads that works as a good sanity check for where the browser thinks it fired onload.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)