Current time: 10-23-2019, 07:57 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Google PSS isn't deferring js
02-04-2013, 03:54 PM (This post was last modified: 02-04-2013 04:07 PM by avalanch.)
Post: #1
Google PSS isn't deferring js
Even with the option enabled..

What can I do to aid it in deferring the js? I'd like to max the score I've got now which is 98 Cool

http://www.webpagetest.org/pagespeed.php...1&cached=0
Visit this user's website Find all posts by this user
Quote this message in a reply
02-04-2013, 04:40 PM
Post: #2
RE: Google PSS isn't deferring caching of js
Google PSS looks interesting. I'm going to try stacking it with Cloudflare to see if doubling up is of any benefit, at least while it's still free.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-05-2013, 01:41 AM
Post: #3
RE: Google PSS isn't deferring js
Actually cloudflare doesn't work at all with Google PSS. I've tried that.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-06-2013, 01:38 AM
Post: #4
RE: Google PSS isn't deferring js
You should ping the team on their discussion group - could be something with the headers on the js or something like that: https://groups.google.com/forum/?fromgro...ce-discuss

Chaining cloudflare and PSS might be possible if you put cloudflare first but adding 2 proxies in front of your content is probably not a great idea.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-06-2013, 08:45 PM (This post was last modified: 02-06-2013 08:46 PM by Chris Stark.)
Post: #5
RE: Google PSS isn't deferring js
I've actual setup a number of sites chaining Cloudflare and PSS after reading this and it works fine. You can see both of them in my page source code. You have to setup the following

A Record > website.com > xxx.xxx.xxx.xxx > Cloudflare Off
A Record > origin.website.com > xxx.xxx.xxx.xxx > Cloudflare On
Cname Record > http://www.website.com > pagespeed.googlehosted.com > Cloudflare On

You also have to add the origin. subdomain at the host. It's pretty impressive stacked together. You can see http://www.digitalmgmt.com example here http://www.webpagetest.org/result/130206_04_CEM/

Under a second on first load and there still more I could do with optimizing PSS. PSS will say that it's not setup in the UI but it's functioning.
Visit this user's website Find all posts by this user
Quote this message in a reply
02-11-2013, 12:21 PM (This post was last modified: 03-01-2018 04:48 AM by avalanch.)
Post: #6
RE: Google PSS isn't deferring js
Unfortunately when I try to enable cloudflare & PSS it gives me this:

DNS Points to Prohibited IP
You've requested a page on a website (https://www.vgchat.us) that is on the CloudFlare network. Unfortunately, it is resolving to an IP address that is creating a conflict within CloudFlare's system. If you are the owner of this website, you should login to CloudFlare and change the DNS A records for https://www.vgchat.us to resolve to a different IP address.

Timestamp: Sun, 10 Feb 2013 18:18:31 -0800

Your IP address: ----

Requested URL: https://www.vgchat.us/forum/forum.php

Error reference number: 1000

Server ID: FL_22F12

Process ID: PID_3ee0aaa972c045b

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17
Visit this user's website Find all posts by this user
Quote this message in a reply
02-15-2013, 09:21 AM
Post: #7
RE: Google PSS isn't deferring js
(02-11-2013 12:21 PM)avalanch Wrote:  Unfortunately when I try to enable cloudflare & PSS it gives me this:

DNS Points to Prohibited IP
You've requested a page on a website (http://www.video-game-chat.com) that is on the CloudFlare network. Unfortunately, it is resolving to an IP address that is creating a conflict within CloudFlare's system. If you are the owner of this website, you should login to CloudFlare and change the DNS A records for http://www.video-game-chat.com to resolve to a different IP address.

Timestamp: Sun, 10 Feb 2013 18:18:31 -0800

Your IP address: ----

Requested URL: http://www.video-game-chat.com/forum/forum.php

Error reference number: 1000

Server ID: FL_22F12

Process ID: PID_3ee0aaa972c045b

User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17


Hi,

Try changing the www record to a gray cloud in your DNS settings that is pointing to Google Pagespeed (you currently have it orange). Curious if that fixes it.


As Patrick mentioned, however, you may not want to stack multiple proxies in front of your site.
Find all posts by this user
Quote this message in a reply
02-16-2013, 05:51 AM
Post: #8
RE: Google PSS isn't deferring js
Yeah, I think I'll just pass on doing that... the downtime isn't very good for the crawlers & people trying to visit my site. For now though google PSS by itself is doing very good.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)