Current time: 11-14-2019, 09:02 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Keep Alive grade
02-07-2013, 01:21 AM (This post was last modified: 02-07-2013 01:25 AM by rviscomi.)
Post: #1
Keep Alive grade
I was trolling the public test results and came across this curious test: http://www.webpagetest.org/result/130206...1/details/

The "Keep Alive Enabled" grade is A but it clearly opens a new connection for all first-party content. Curious if this is intentional or a bug.

Thanks

Edit: This test shows similar behavior: http://www.webpagetest.org/result/130206...1/details/
Visit this user's website Find all posts by this user
Quote this message in a reply
02-08-2013, 03:04 AM
Post: #2
RE: Keep Alive grade
That test failed in some way, i've seen this a few times.

@hsiboy

(02-07-2013 01:21 AM)rviscomi Wrote:  I was trolling the public test results and came across this curious test: http://www.webpagetest.org/result/130206...1/details/

The "Keep Alive Enabled" grade is A but it clearly opens a new connection for all first-party content. Curious if this is intentional or a bug.

Thanks

Edit: This test shows similar behavior: http://www.webpagetest.org/result/130206...1/details/
Find all posts by this user
Quote this message in a reply
02-14-2013, 04:38 AM
Post: #3
RE: Keep Alive grade
Looks like the logic is getting confused by:

Code:
Connection: keep-alive, close

I don't see anything in the specs that expect both to be there but clearly my code is seeing the keep-alive first and trusting it while browsers are seeing the close and honoring that.

I created an issue to track it- http://code.google.com/p/webpagetest/iss...ail?id=141
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)