Current time: 12-07-2019, 01:43 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
initial connect always at 3179ms
04-21-2013, 04:39 AM
Post: #1
initial connect always at 3179ms
Hello
Title says it all really. Im trying to optimise this site the result shows that each time my initial connect time is around 3179ms and with all the requests that all adds up to results of at least 20s

http://www.webpagetest.org/result/130420_6M_QKF/

Please help
Find all posts by this user
Quote this message in a reply
04-24-2013, 12:31 AM
Post: #2
RE: initial connect always at 3179ms
Wow, that's insane and not something I have ever seen before. Are you running your own server stack or is it running on a shared server? It looks like a serious problem with the Apache config.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-24-2013, 12:50 AM
Post: #3
RE: initial connect always at 3179ms
Im running Joomla 1.5 on a basic hosting package from lunarpages (hence probably shared). I assumed the slow speed was just the fact it was either an old joomla version (but the new upgrade im now testing is showing similar results) or the fact that its a basic hosting plan. Now that ive found this test it seems like something else entirely. I wanted to check if it was something basic i was doing wrong before contacting lunarpages

Im a bit clueless with regards to hosting etc so not sure what other information i should include here but heres a list from my hosting control panel
Operating System CentOS release 5.4 (Final)
Kernel Version 2.6.18-164.11.1.el5PAE
Apache Version 2.2.3
MySQL Version 5.0.77
PERL Path /usr/bin/perl
PERL Version 5.8.8
PHP Path /usr/bin/php
PHP Version 5.3.14
PHP53 Path /opt/php53/bin/php
PHP53 Version 5.3.14
Ruby Path /usr/local/bin/ruby
Ruby Version 1.9.3
Find all posts by this user
Quote this message in a reply
04-24-2013, 01:16 AM
Post: #4
RE: initial connect always at 3179ms
I'd contact lunarpages. Beyond the rediculously slow connect times, the server isn't permitting keep-alive connections so it is having to re-connect (slowly) for every request. Some shared hosting providers disable keep-alive because they are too over-subscribed to support it but it's borderline criminal to do that.
Visit this user's website Find all posts by this user
Quote this message in a reply
04-24-2013, 01:40 AM
Post: #5
RE: initial connect always at 3179ms
thanks. will do
Find all posts by this user
Quote this message in a reply
05-02-2013, 10:09 PM (This post was last modified: 05-02-2013 10:13 PM by ash.)
Post: #6
RE: initial connect always at 3179ms
Hi

Some time ago I investigated similar problem. The cause was network-level. Some issues regarding congestion window and default setting in Windows 7. I can not find the solution and detailed description of it at the moment.

Regards

Try read this: http://blog.tmcnet.com/blog/tom-keating/...solved.asp

In my case it helped.

Artur Sudnik
Find all posts by this user
Quote this message in a reply
05-29-2013, 04:00 AM
Post: #7
RE: initial connect always at 3179ms
Forgot to come back here when i got it sorted. In case it helps anyone, my sites database was not on the same server as the site. Lunarpages moved me over to a different server with the mysql database on the same server and cpanel control panel instead of the lunarpanel (i dont think that made a difference but it came with the change in server).

Either way it changed my load time down to a few seconds
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)