Current time: 01-16-2021, 01:45 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WPT private instance not working for FF or Chrome
04-23-2013, 11:55 PM
Post: #3
RE: WPT private instance not working for FF or Chrome
(04-23-2013 06:19 AM)andydavies Wrote:  To me this sounds like a mismatch between locations.ini on the server and wptdriver.ini on the test agent.

What does path.to.your.wpt.server/getLocations.php show you - are there any Chrome or Firefox agents connecting?

Also check the access.log for Apache (or which ever httpd you're using) to see if there are requests coming in for Chrome and Firefox they'll look something like:

GET /work/getwork.php?location=name of wpt driver location&software=wpt&ver=62&pc=WIN7VM-PC&freedisk=2.062

Hi,

Here are the contents of locations.ini and wptdriver.ini:
-----
[locations]
1=Local
default=Local

[Local]
1=Local-URLBlast
2=Local-WPTDriver
label=Local

[Local-URLBlast]
browser=IE 9
latency=0
label="Local - IE 9"
browserExe=pagetest.exe
key=SomeKey123

[Local-WPTDriver]
browser=Chrome,Firefox
label="Local - Agents"
key=SomeKey123
-----
[WebPagetest]
url=http://127.0.0.1/
location=Local-WPTDriver
browser=Chrome,Firefox
software=http://www.webpagetest.org/installers/software.dat
debug=0

[Chrome]
exe="C:\Program Files\Google\Chrome\Application\chrome.exe"
options='--load-extension="%WPTDIR%\extension" --user-data-dir="%PROFILE%" --no-proxy-server'
installer=http://www.webpagetest.org/installers/browsers/chrome.dat
key=SomeKey123

[Firefox]
exe="C:\Program Files\Mozilla Firefox\firefox.exe"
options='-profile "%profile%" -no-remote'
installer=http://www.webpagetest.org/installers/browsers/firefox.dat
template=firefox
key=SomeKey123
-----

Here is the output of getLocations.php:
-----
Location Idle Testers Total Tests Being Tested High Priority P1 P2 P3 P4 P5 P6 P7 P8 P9
Local-URLBlast 1 0 0 0 0 0 0 0 0 0 0 0 0
Local-WPTDriver:Chrome 1 6 0 6 0 0 0 0 0 0 0 0 0
Local-WPTDriver:Firefox 1 6 0 6 0 0 0 0 0 0 0 0 0
-----

Here are the request from the acess log and wpt log:

-----
127.0.0.1 - - [22/Apr/2013:16:21:58 -0400] "GET /work/getwork.php?shards=1&location=Local-WPTDriver&software=wpt&ver=99&pc=WPT01&dns=10.x.x.x-10.x.x.x&freedisk=28.139 HTTP/1.1" 200 -
-----
2013-04-22 16:21:58 10.x.x.x 0 0 130422_HV_24 http://www.somesite.com Local - Agents - <b>Firefox</b> - <b>Cable</b> 0 0 21ec006198e0708c062555d9e137c148ce37fd4c
-----

Thanks
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
RE: WPT private instance not working for FF or Chrome - meng.fu - 04-23-2013 11:55 PM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)