Current time: 12-07-2019, 11:21 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[split] Server and client on same machine for private instance
07-03-2013, 02:57 AM
Post: #1
Smile [split] Server and client on same machine for private instance
(06-28-2013 12:55 AM)pmeenan Wrote:  Also make sure you installed dummynet. That is the most common cause for "The test completed but there were no successful results"

Mr Pat sir. How has the world been treating you these days? Glad to see you're still working on this project. Very glad, in fact, as I have a question. Big Grin

I'm currently using a private instance w/client on the same machine, but I need to be able to hit a series of pages on an internal network. When I go to any of them, the server pops an error message that the site(s) I'm trying to reach must be on a public-facing web server. I'm pretty sure I've got the bulk of it configured properly since it can hit any public site just fine and generates all the expected data. While the stand-alone Pagetest works through the browser to access the internals, I need to run a bunch of regression testing and was hoping to script a lot of it (any updated scripting commands, btw?). I looked around and the only reference I could find to the public-facing site requirement was the actual error message in the code. Most likely I have something simple set wrong, or is the server-side not that friendly about doing isolated intranet testing like that?

Thanx

Robert Lilly
Find all posts by this user
Quote this message in a reply
07-03-2013, 09:43 AM
Post: #2
RE: [split] Server and client on same machine for private instance
Hey Robert, long time no chat!

There is a setting in the settings.ini on the server "allowPrivate". Set it to =1 and it should start allowing tests from private IP ranges.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-05-2013, 10:33 PM
Post: #3
RE: [split] Server and client on same machine for private instance
(07-03-2013 09:43 AM)pmeenan Wrote:  There is a setting in the settings.ini on the server "allowPrivate". Set it to =1 and it should start allowing tests from private IP ranges.

Perfect! Thank you very much. With everything else working as it should, I knew it was something simple hiding somewhere that I'd forgotten to flip. Greatly appreciate it.

Robert
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)