Current time: 11-22-2019, 03:35 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weird Results?
12-11-2013, 04:52 PM
Post: #11
RE: Weird Results?
Hi,

Kudo to Patrick, Robzilla, iSpeedlink, i managed to lower my speed to 12 sec Sad

here is my results : http://www.webpagetest.org/result/131210_X2_VNK/

The test result shows grade A is almost every aspects but my time is far to slow, 12secs. and Ive change my host to a localize host (site5 - singapore). do you guy think, i should upgrade my server from basic plan to VPS or ?

And is there any way i can test my site accurately in singapore? my site is meant for the singaporean customers only?

Thanks in advance.

Cheers,
Find all posts by this user
Quote this message in a reply
12-11-2013, 09:05 PM
Post: #12
RE: Weird Results?
Your problem is still that you're loading too many images on that one page. So many, in fact, that it freezes my browser until it's done. And most of the images aren't even visible on the page without scrolling left and right. Best to load those only when needed.
Find all posts by this user
Quote this message in a reply
12-11-2013, 09:40 PM
Post: #13
RE: Weird Results?
Robzilla,

"Best to load those only when needed" How do i do this ? only load when the image is visible on the homepage, it will definitely speed thing up… then the rest of the images can load when is needed.
any plugins or solutions?

Cheers,
Find all posts by this user
Quote this message in a reply
12-12-2013, 12:17 AM (This post was last modified: 12-12-2013 12:18 AM by robzilla.)
Post: #14
RE: Weird Results?
You'd probably have to customize the plug-in you currently use to create the image sliders, reduce the number of images, or replace it with a different slider. Do you really need to display all those images in your sliders? Won't a small sampling of your furniture suffice?
Find all posts by this user
Quote this message in a reply
12-12-2013, 01:58 AM (This post was last modified: 12-12-2013 01:59 AM by cultdevision.)
Post: #15
RE: Weird Results?
Robzilla,

Hmm.. i'll have to reduce the images loaded on my homepage. Sad Thanks for your advice.
Find all posts by this user
Quote this message in a reply
12-12-2013, 01:54 PM (This post was last modified: 12-12-2013 02:06 PM by iSpeedLink.com.)
Post: #16
RE: Weird Results?
You are still using png for photographic images. When the image is a photo you should almost always use jpg.

The latest results you post today were for IE8 Browser. Why? Your page does not render or function correctly in IE8. IE8 accounts for 7% of Singapore users.

http://ispeedlink.com/ie8.jpg

That's not the worst of it. Once the page loads, on the one gallery slider that does render the "Next: arrow does not work.

The Opera Browser while not very popular is a good benchmark of a well designed web page. A well designed page will render perfectly in Opera. You page does not render anywhere close to acceptable in Opera. here is a screen shot from Opera.

http://ispeedlink.com/opera.jpg

You ask if there is a plug-in solution. Plug-ins are at the root of your problems. A 12 second page load is the best you can expect when you use Word Press and too many plug-ins.

Yes you have five grades of A and one grade F. The five A's are important, but your one F is so serious the five A's will do you no good. You had the same five A's when you had a 66 second page load.

A well designed website will not use javaScript and will only use HTML and CSS for the first view. Your site will not render or function without javaScript.

You problem is the fundamental design is seriously flawed.

Go back to the drawing board. Remove all plug-ins. Get the site functional with no plug-ins.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)