Current time: 11-22-2019, 12:37 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Visually Complete & Speed Index no longer returning
02-26-2014, 05:38 AM
Post: #1
Visually Complete & Speed Index no longer returning
I noticed that since around Feb 17 or 18 I no longer see Visually Complete & Speed Index returning in the XML results from a webpagetest run. Have these metrics been removed?

Example:
Feb 18
http://www.webpagetest.org/xmlResult/140218_QN_14GQ/
<date>1392741263</date>
<effectiveBps>277905</effectiveBps>
<effectiveBpsDoc>285922</effectiveBpsDoc>

Feb 17
http://www.webpagetest.org/xmlResult/140217_E6_YXD/
<date>1392654156</date>
<SpeedIndexDT>1720</SpeedIndexDT>
<SpeedIndex>1720</SpeedIndex>
<VisuallyCompleteDT>1845</VisuallyCompleteDT>
<renderDT>1138</renderDT>
<effectiveBps>305804</effectiveBps>
<effectiveBpsDoc>332781</effectiveBpsDoc>
Find all posts by this user
Quote this message in a reply
02-26-2014, 06:27 AM
Post: #2
RE: Visually Complete & Speed Index no longer returning
Looks like your Feb 18 test didn't capture video. Did you pass video=1 with the test (or check the box in the UI)?
Visit this user's website Find all posts by this user
Quote this message in a reply
02-27-2014, 12:49 AM
Post: #3
RE: Visually Complete & Speed Index no longer returning
(02-26-2014 06:27 AM)pmeenan Wrote:  Looks like your Feb 18 test didn't capture video. Did you pass video=1 with the test (or check the box in the UI)?

I didnt pass that in with either of those. Requests. I have a script that runs daily at 4pm using Ruby I set the following as the request: "http://www.webpagetest.org/runtest.php?runs=1&f=xml&fvonly=1&url=#{test_url}&k=#{@APIkey}"

Is the visually complete and speed index metrics only for video display purposes? If so I can remove it as I dont need that really.
Find all posts by this user
Quote this message in a reply
02-27-2014, 11:42 AM
Post: #4
RE: Visually Complete & Speed Index no longer returning
They are calculated based on the video data. There is another version of it that calculates the information based on paint events and it used to pick whichever was available (and the paint events were kind of sketchy on non-Chrome) - they have separate event names now and I eliminated the sketch events which is probably why it stopped showing up.

To be clear, video=1 records video of your page loading and has a lot of useful information (and allows for the filmstrip view where you can interact with the waterfall and video frames) - it doesn't have anything to do with sites that display video themselves.
Visit this user's website Find all posts by this user
Quote this message in a reply
05-05-2014, 04:48 PM (This post was last modified: 05-09-2014 08:09 PM by timir126.)
Post: #5
RE: Visually Complete & Speed Index no longer returning
Hi Patrick,
I'm unable to get PageSpeed score in the response if running the test

e.g. http://www.webpagetest.org/result/140509...e_data.csv


Please help.

Regards,
Vishnu
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)