Current time: 11-20-2019, 09:16 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
gap between html and first file
03-11-2014, 06:00 AM
Post: #1
gap between html and first file
I'm setting up a new web server, and this is a static html site that's being used as the first test. It's a big dedicated server, so performance is expected to be pretty good! Environment is CentOS 6 / nginx. I have a dead space between the delivery of the html and the style.css - the first required file. Is his something that I can reduce from the server side?

http://www.webpagetest.org/result/140310_J2_YE0/

Cheers,

Steve
Find all posts by this user
Quote this message in a reply
03-11-2014, 06:10 AM
Post: #2
RE: gap between html and first file
It depends on what's in the html. You can try on a faster test system to see if it's mostly just an issue of an under-powered test agent (the Dulles Thinkpads are dedicated core i5's and should give you a good floor).

If there's a lot of script or complicated layout then it's possible that it's taking the browser that long to chug through it. It may not start on resource requests (Chrome anyway) if the main thread has a lot of contiguous work to do. You can capture a dev tools timeline to get a better idea of what the browser is doing.
Visit this user's website Find all posts by this user
Quote this message in a reply
03-12-2014, 07:16 PM
Post: #3
RE: gap between html and first file
I'd start with removing one doctypes, you have two of them for which I see no reason. Simply put <!DOCTYPE html> and see what happens. Then, you are using highslide.js but I see you are using mainly to show bigger images and I'd recommend slimbox. And I'd move language declaration up, just below <title>.
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)