Current time: 12-11-2019, 12:59 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
gaps in waterfalls with ie
04-28-2014, 06:17 PM
Post: #1
gaps in waterfalls with ie
Hi,

we measure with an own wpt-infrastructure. In measurements of internet explorer (we use version 10) we have lot of gaps in waterfalls. I can reproduce these gaps in measurements on webpagetest.org, too: http://www.webpagetest.org/result/140428...1/details/
So far I thought these gaps are caused by preconnections the browser initiates for the (follow-up-)domains he expects to be requested after the main-domain of the site. But this doesn't explain the (large) gaps in the initial html-request?!
We don't see these gaps in firefox-tests, e.g. http://www.webpagetest.org/result/140428...1/details/

Any ideas what else could cause these gaps in internet explorer-measurements?

Regards, Nils
Find all posts by this user
Quote this message in a reply
04-29-2014, 04:28 AM
Post: #2
RE: gaps in waterfalls with ie
Slim the site down. You are loading 1.4 MB on browsers.

Start here, save almost 500kb just by optimizing these JPEG images:

http://www.webpagetest.org/result/140428...ssive_jpeg

That will trim your pageload by 8% without losing any content or quality.

Here's all your images.

Everywhere on that page you see "Analyze JPEG" clicking on that will send you to a page where WPT actually optimizes these images for you, for free! Pick the one with the smallest KB size, download to your computer, rename to match its name on the server, and upload to same location to overwrite.

Do this on all needed and then let's see how parallel downloads look.

You're also, not leveraging browser cache of static content. If you're on a linux server this is a easy fix using the .htaccess file. Let me know if you want the code.
Find all posts by this user
Quote this message in a reply
04-29-2014, 05:06 AM
Post: #3
RE: gaps in waterfalls with ie
My guess is that the gaps are actually the certificate revocation checks or other SSL stuff. I'll see if I can find a way to get better instrumentation out of IE and at least include that time in the SSL negotiation time.

It's particularly telling that the SSL blocks look to be about the same size as the connect blocks but AFAIK IE doesn't do TLS Snap Start so it should be at least 2 round trips for getting most of those SSL connections established.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)