Current time: 08-24-2019, 05:30 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Full load time
11-25-2014, 04:07 PM
Post: #1
Full load time
Definition:The Fully Loaded time is measured as the time from the start of the initial navigation until there was 2 seconds of no network activity after Document Complete.

Is it possible to increase/change this 2s time period, as my test loads a document and the network inactivity period between the initial page and the doc to load > 2s. So the the webpagetest completes even before the document loads fully

In which script should I make changes if I need to change this hard coded 2s to a greater value

Your help is much appreciated
Find all posts by this user
Quote this message in a reply
11-26-2014, 12:28 AM
Post: #2
RE: Full load time
The 2s is hard-coded in the c++ agent code. You can use the "minimum duration" to force it to wait a minimum of X seconds for the full test. It will still trim to the actual activity so that may be a way to get what you need without making changes.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-26-2014, 04:27 PM
Post: #3
RE: Full load time
Can you please let me know which file and what changes needs to be done on it?
Find all posts by this user
Quote this message in a reply
11-27-2014, 07:52 AM
Post: #4
RE: Full load time
Hmm, apparently there is a script command that you can use to override it (in ms) - setactivitytimeout

Code:
setactivitytimeout    5000

Otherwise you want to change it in wpt_settings.h and rebuild wptdriver.exe and wpthook.dll - https://github.com/WPO-Foundation/webpag...ings.h#L38
Visit this user's website Find all posts by this user
Quote this message in a reply
12-02-2014, 03:14 PM
Post: #5
RE: Full load time
when I use setactivitytimeout 5000 in script, the fully loaded time, I see in the summary (the box which aggregates the results) is not compliant with the time I see in waterfall chart. The waterfall chart shows a greater value, which is the actual load time.

Instead, if I set 'minimum test duration' under advanced tab, the fully load time shown is in accordance with the waterfall chart.

Help me understand, in what way they are different
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)