Current time: 10-24-2019, 02:34 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EC2 Server AMI / Testsettings/Content missing
11-25-2014, 11:19 PM
Post: #1
EC2 Server AMI / Testsettings/Content missing
Hello!

I spinned up an EC2 server AMI.
-> https://github.com/WPO-Foundation/webpag...r%20AMI.md

Now I've got the problem that the testsettings are (content is) mising at my private instance page.

Only the header navigation, including "home", "test history" etc. is visible.

The firewall settings are
Inbound
SSH, TCP: 22, IP: 0.0.0.0/0
HTTP, TCP: 80, IP: 0.0.0.0/0

Outbound
All traffic, All protocols, All ports, IP: 0.0.0.0/0

And EC2 key + secret is set via user data.

Any ideas what can be the problem?

Best,
Florian

[Image: 6567555?AWSAccessKeyId=0R7FMW7AXRVCYMAPT...EFZtxjc%3D]
Find all posts by this user
Quote this message in a reply
11-26-2014, 12:41 AM
Post: #2
RE: EC2 Server AMI / Testsettings/Content missing
By default the server AMI is configured as a headless instance which kills most of the UI unless you are looking at a test result. You can enable the full UI by specifying headless=0 in the user data when you start it up or for a running instance go into /var/www/webpagetest/www/settings/settings.ini and remove the headless=1 entry.
Visit this user's website Find all posts by this user
Quote this message in a reply
11-27-2014, 12:23 AM
Post: #3
RE: EC2 Server AMI / Testsettings/Content missing
(11-26-2014 12:41 AM)pmeenan Wrote:  By default the server AMI is configured as a headless instance which kills most of the UI unless you are looking at a test result. You can enable the full UI by specifying headless=0 in the user data when you start it up or for a running instance go into /var/www/webpagetest/www/settings/settings.ini and remove the headless=1 entry.

Thank you very much!
By removing "headless=1" in /var/www/webpagetest/www/settings/settings.ini it works Smile

Best,
Florian
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)