Current time: 09-23-2019, 09:50 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Extra request to rapidssl
01-01-2015, 07:26 AM
Post: #1
Extra request to rapidssl
Hello. I've noticed that whenever i run a test by firefox or firefox nightly to https protocol website, test result waterfall has a request to http://rapidssl-ocsp.geotrust.com/

As far as i know the target first time byte is calculated, based on times of first request, therefore giving wrong results.

here is an example:
http://www.webpagetest.org/result/141231...1/details/

webpagetest says that expected FTB is 87ms, although it should be 173ms(SSL)+3*76ms(connect time) = 401ms.
or
28ms(DNS)+173ms(SSL)+76ms(connect)+100ms=377ms.

But surely not 87ms.

This messes up a lot of results, and, from client point of view, shows that optimizations made load times worse (judging by grades). Which is not cool.

If i'm missing a part of brain - please, advise Smile

Thanks.
Find all posts by this user
Quote this message in a reply
01-16-2015, 06:16 AM
Post: #2
RE: Extra request to rapidssl
Sorry, you're correct - that's a bug. I opened an issue to track it: https://github.com/WPO-Foundation/webpag...issues/383

That said, you should be using ocsp certificate stapling so the browser doesn't have to make the external request to check the certificate.
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)