Current time: 08-04-2020, 04:15 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
First Byte issues
05-26-2015, 06:08 AM
Post: #1
First Byte issues
http://www.webpagetest.org/result/150525_KD_Y3W/

Hi,
I've inherited a IIS 7.5 server running PHP 5.3.8 and MySQL. The first byte is always high, usually between 5-9s, even with a static page. I've been looking everywhere, but can't find anything. I'm more experienced with linux and apache, this microsoft environment is slowing me down. Any help would be welcome thanks.

I've search through many threads but so many are unique, I've tried some of the suggestions.

Thanks
Find all posts by this user
Quote this message in a reply
05-27-2015, 09:45 PM
Post: #2
RE: First Byte issues
It could be that the windows server is a little under powered or there are internal network problems. Try doing a trace route to the server to determine whether it is a problem on the server, or within the internet itself.

I specialise in speeding up websites.

Want a free quote? Just give us a private message and we'll see what we can do for you.
Find all posts by this user
Quote this message in a reply
05-28-2015, 01:44 AM
Post: #3
RE: First Byte issues
I think I'd start with MySQL tuning. Slow queries, check, optimize index tables, ensure database has memory assigned etc.
PHP opcode caching might not hurt along with a different method of page caching for the pages that are largely static.

Since you are familiar with Apache, perhaps migrate the site to that from IIS?
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 2 Guest(s)