Current time: 06-26-2019, 08:14 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FBT varies greatly between tests
06-29-2015, 09:27 PM (This post was last modified: 06-29-2015 09:45 PM by graphicsxp.)
Post: #1
FBT varies greatly between tests
Hi,

Here's the test results:

At 11.40AM Today:

http://www.webpagetest.org/result/150629_9Z_G1X/

At 12.40AM Today:

http://www.webpagetest.org/result/150629_HZ_J0J/

I run the tests from Paris, because that's where my server is hosted and my business is mostly in France and near countries.

The site is a Wordpress site running on a dedicated Ubuntu server with the following hardware configuration:

1x IntelĀ® C2750 (Avoton) 8 cores 8 threads @2.4 Ghz
8 GB DDR3 ECC
1 TB SATA3
1 Gbit/s connection
1 Gbit/s intrenal bandwidth
200 Mbit/s Internet bandwidth

I have installed W3 Total Cache and it is configured to cache pages, objects and database using APC method.

Also, I've noticed that testing another page of my website gives always a F grade: http://www.webpagetest.org/result/150629_SX_KT3/

So to sum it up, for the home page, the FBT varies from B to F but for one other page, it is always F.
I don't understand this variation in FBT so any clues would be appreciated !
Find all posts by this user
Quote this message in a reply
06-29-2015, 10:37 PM
Post: #2
RE: FBT varies greatly between tests
Never make single test. On front page there's option where you can specify number of tests to perform - put 9 tests and then come back with results.

As for your question - reasons may vary, the most common ones is 'cold' cache (for example cache entry exceeded its lifetime, cache entry has been flushed due to recent changes etc. ).
Find all posts by this user
Quote this message in a reply
06-30-2015, 03:49 AM
Post: #3
RE: FBT varies greatly between tests
I have followed your advice and run a few series of 9 tests. The results are consistent:

home page, grade A: http://www.webpagetest.org/result/150629_98_YXF/

home page, grade C: http://www.webpagetest.org/result/150629_S4_XTM/

Any page, other than home, grade F: http://www.webpagetest.org/result/150629_6J_X7N/ this page in particular is not doing anything special a part from displaying some text and an image....

I have run the same test with Google Speed Insight and I get the exact same results regarding TTFB. I get no warning on home page, but on any other pages Google complains that I need to speed up my website response time.

I don't understand why the home page is performing rather well, but not the others. Any idea someone ?
Find all posts by this user
Quote this message in a reply
06-30-2015, 06:33 AM
Post: #4
RE: FBT varies greatly between tests
It looks like the page cache is expiring often on the home page, causing the longer load times. By default W3TC sets the page expiry to one hour. I recommend changing this to best suit how often your website is updated. Using the prime cache feature in W3TC will also help to prevent the chances of a user coming across a page with an expired cache.

Viewing the site with a fresh cache will return a much quicker result.

Make sure to test the inside pages with the exact URL, with the backslash on the end. Testing a slightly different URL will cause WordPress to send a redirect causing the longer load times: eg
http://www.joliehistoire.com/le-blog/ instead of
http://www.joliehistoire.com/le-blog

The ttfb seems quite slow (almost 2s) especially for a dedicated server. I would experiment with turning off database and object caching. Install and test the load time of a fresh WP install to see if either your server or Wordpress installation needs tweaking.
Visit this user's website Find all posts by this user
Quote this message in a reply
06-30-2015, 07:09 AM (This post was last modified: 06-30-2015 07:55 AM by graphicsxp.)
Post: #5
RE: FBT varies greatly between tests
Probably the cache expires because I'm working on it and I've been purging cache quite often in the last hour. Otherwise it is set to default value of 1H, which I think is good.
I do use the prime cache feature already (900 seconds interval and 50 pages per interval)

I have installed a fresh wordpress and I accessed it via another domain name (on the same server). No plugins and no content obviously, but he ftb gave me a grade D, so I think this is pretty bad.

I went back to my main website, de-activated all plugins, reset to default wordpress theme and even restarted the server to free up some ram... Still getting a bad TTFB

BUT... I had forgotten the trailing slash as you mentionned it. Just run the test on an inner page with the trailing slash and I'm getting a grade A. What puzzles me is why on first view the TTFB is 0.172 and on repeat view it is 0.722.

I'm surprised you got 2s. It might be that you run the test when I had just restarted the server or something like that...

oh and I've run the test again with Google Page Speed. This time with a trailing slash and I no longer get the warning about slow ttfb, and my score is much higher.
It looks like this was the biggest issue and I was not running the tests against the correct url

And also, I just re-activated Cloudflare and now my TTFB is back to grade B or lower. I've read somewhere that webpagetest does not play nice with cloudflare. In fact, google page speed keeps telling me the server responds fast, so nothing to worry about. Just in case you wonder why my TTFB is no longer grade A Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)