Current time: 10-15-2019, 07:35 AM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Missing Document complete stats
08-04-2015, 08:20 PM
Post: #1
Missing Document complete stats
Hi I have been running a scripted test from our private instance here> http://wpt.intechnica-dev-1.co.uk/result...8ee51ac3b/


It appears to execute OK, and to capture all elements in the test page (looking at the waterfall).
However, Document complete timings are not collected (reported as 0s) and associated metrics eg # DOM elements are missing. The attached screengrab illustrates.

Is there a usual cause for this/what would you advise?

Thanks

ATB

Larry


Attached File(s) Image(s)
   
Find all posts by this user
Quote this message in a reply
08-05-2015, 01:40 AM (This post was last modified: 08-05-2015 06:49 PM by Lazmonster.)
Post: #2
RE: Missing Document complete stats
Checkout this one also (error code 999999) [below]
Find all posts by this user
Quote this message in a reply
08-05-2015, 06:48 PM
Post: #3
RE: Missing Document complete stats
   
Screengrab attached
Find all posts by this user
Quote this message in a reply
08-07-2015, 02:07 AM
Post: #4
RE: Missing Document complete stats
Hard to say without knowing what the script is doing. If it is triggering an action that isn't a page navigation (like in a single page app, just switching UI around, etc) then there is no document complete (onload) event to measure.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-07-2015, 02:10 AM (This post was last modified: 08-07-2015 02:16 AM by Lazmonster.)
Post: #5
RE: Missing Document complete stats
(08-07-2015 02:07 AM)pmeenan Wrote:  Hard to say without knowing what the script is doing. If it is triggering an action that isn't a page navigation (like in a single page app, just switching UI around, etc) then there is no document complete (onload) event to measure.

Thanks Pat

Its a very straightforward script - navigate to betfair.com landing page, launch 'all sports' page, then tennis page.
Script is here for good measure>
//Betfair.com Tennis Page script
logData 0
navigate http://www.betfair.com/sports
clickAndWait id=SPORTSBOOK
logData 1
execAndWait document.querySelector(".ui-clickselect > *[href='/sport/tennis']").click()

It may be that a lot of content has been preloaded, but it is not an SPA per se, and a fair amount (though not lots, I admit) of elements appear to be downloaded.

Is there any way of getting around this, or are we snookered with this site?

Thanks for the feedback

ATB

Larry
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)