MyBB Internal: One or more warnings occured. Please contact your administrator for assistance.
Script tests don't work well
Current time: 01-17-2021, 11:49 PM Hello There, Guest! (LoginRegister)

Post Reply 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Script tests don't work well
02-18-2016, 04:36 PM
Post: #1
Script tests don't work well
We use script testing to test a page which needs sign in. The script looks like below. We add "waitForComplete" to make sure the test ends until the page rendering is complete. However, we still see some incomplete tests. Please find the attachment for screenshot.

The major issues are as below. I'm wondering if there's any log we can check what's happening during the test. Why are these data missing or incomplete?
1. No ranking after all tests are complete.
2. The test ends before the target page is rendering sometimes. So we'll see the homepage instead of the target page in the screenshot.

Code:
logData    0
//navigate to sign in page
navigate https://signin.ebay.com
//login    with your credentials
setValue    name=userid USERNAME
setValue    name=pass      PASSWORD
submitForm    name=SignInForm
waitForComplete
logData    1
//navigate    to testing page
navigate    https://xxx.ebay.com/xxx/xxx
waitForComplete

   
   
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
Script tests don't work well - sally - 02-18-2016 04:36 PM
RE: Script tests don't work well - sally - 02-19-2016, 11:00 AM
RE: Script tests don't work well - pmeenan - 02-24-2016, 01:11 AM

Forum Jump:


User(s) browsing this thread: 1 Guest(s)